summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia
diff options
context:
space:
mode:
authorAzril Ahmad <mohd.azril.ahmad@intel.com>2016-04-16 09:07:30 +0800
committerSaul Wold <sgw@linux.intel.com>2016-04-20 05:42:00 -0700
commitc55d0f0549b1cd98083c2f0233f45032e9c4ae54 (patch)
tree0069fabd940d81cd948bc08b54d3288579f96bcd /common/recipes-multimedia
parentc5650b6811f58c27d7d4493864b3ca859cf66cbd (diff)
downloadmeta-intel-c55d0f0549b1cd98083c2f0233f45032e9c4ae54.tar.gz
gstreamer-vaapi: Backport the HEVC decode fix for Matroska (.mkv) container
Backport the gstreamer-vaapi upstreamed patch to fix the HEVC decoding that failed on Matroska (.mkv) video container. This patch was imported from gstreamer-vaapi FreeDesktop git server (git://anongit.freedesktop.org/gstreamer/gstreamer-vaapi) as of commit id : a486942ba2d44ba2f60fec25175c681786021b48 to fix the BugZilla #762922 defect. (https://bugzilla.gnome.org/show_bug.cgi?id=762922) Signed-off-by: Azril Ahmad <mohd.azril.ahmad@intel.com> Signed-off-by: Chang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-multimedia')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.7.0.bb2
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi/0001-decoder-h265-Fix-offset-calculation-in-codec_data-pa.patch31
2 files changed, 33 insertions, 0 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.7.0.bb b/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.7.0.bb
index cdcac54d..be8f47a7 100644
--- a/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.7.0.bb
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_0.7.0.bb
@@ -4,3 +4,5 @@ DEPENDS += "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
4 4
5SRC_URI[md5sum] = "ce2d4921b8d9c78edd609d95e8c502d3" 5SRC_URI[md5sum] = "ce2d4921b8d9c78edd609d95e8c502d3"
6SRC_URI[sha256sum] = "abe8ea4dfb3177d038b38610537c651b943707ed110882782a19b95a9ea04a92" 6SRC_URI[sha256sum] = "abe8ea4dfb3177d038b38610537c651b943707ed110882782a19b95a9ea04a92"
7
8SRC_URI =+ "file://0001-decoder-h265-Fix-offset-calculation-in-codec_data-pa.patch"
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/0001-decoder-h265-Fix-offset-calculation-in-codec_data-pa.patch b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/0001-decoder-h265-Fix-offset-calculation-in-codec_data-pa.patch
new file mode 100644
index 00000000..92a6f083
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/0001-decoder-h265-Fix-offset-calculation-in-codec_data-pa.patch
@@ -0,0 +1,31 @@
1From dd227da41e953e79c8e05cd6f838a0e267d2d9b5 Mon Sep 17 00:00:00 2001
2From: Sreerenj Balachandran <sreerenj.balachandran@intel.com>
3Date: Fri, 11 Mar 2016 17:44:07 +0200
4Subject: [PATCH] decoder: h265: Fix offset calculation in codec_data parsing
5
6Upstream-status: Backport
7
8https://bugzilla.gnome.org/show_bug.cgi?id=762922
9
10Signed-off-by: Sreerenj Balachandran <sreerenj.balachandran@intel.com>
11Signed-off-by: Azril Ahmad <mohd.azril.ahmad@intel.com>
12Signed-off-by: Chang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com>
13---
14 gst-libs/gst/vaapi/gstvaapidecoder_h265.c | 1 +
15 1 file changed, 1 insertion(+)
16
17diff --git a/gst-libs/gst/vaapi/gstvaapidecoder_h265.c b/gst-libs/gst/vaapi/gstvaapidecoder_h265.c
18index 3c5a9d9..fd8250a 100644
19--- a/gst-libs/gst/vaapi/gstvaapidecoder_h265.c
20+++ b/gst-libs/gst/vaapi/gstvaapidecoder_h265.c
21@@ -2688,6 +2688,7 @@ gst_vaapi_decoder_h265_decode_codec_data (GstVaapiDecoder *
22 goto cleanup;
23 break;
24 }
25+ ofs = pi->nalu.offset + pi->nalu.size;
26 gst_vaapi_parser_info_h265_replace (&pi, NULL);
27 }
28 }
29--
301.9.1
31