summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-10-18 23:41:38 +0100
committerTom Zanussi <tom.zanussi@intel.com>2013-11-04 16:47:59 -0600
commitbfb34edf5a9e00b3a15cf7b9bb2630d3d749006f (patch)
tree006c5cd878ebf2aef278f63faffc3e56d3f20576 /common/recipes-multimedia
parentebf255564f43b193d7d6426f79ada9b143790867 (diff)
downloadmeta-intel-bfb34edf5a9e00b3a15cf7b9bb2630d3d749006f.tar.gz
gstreamer-vaapi: upgrade to 0.4.3
Use tarballs instead of git tags (upstream git means using submodules, which are tricky). Also use PACKAGECONFIG to respect x11/wayland DISTRO_FEATURES. Delete glib-includes.patch, as it wasn't being used. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-multimedia')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi/glib-includes.patch49
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi_0.4.3.bb24
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb37
3 files changed, 24 insertions, 86 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/glib-includes.patch b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/glib-includes.patch
deleted file mode 100644
index 381e507e..00000000
--- a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/glib-includes.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1commit a698766a8b155b9c282ee1d53c39a833c826616d
2Author: Gwenole Beauchesne <gwenole.beauchesne@intel.com>
3Date: Tue Feb 7 10:01:01 2012 +0100
4
5 glib: fix includes.
6
7Upstream-Status: Backport
8
9Signed-off-by: Tom Zanussi <tom.zanussi (a] intel.com>
10
11Index: git/gst-libs/gst/vaapi/gstvaapiutils.h
12===================================================================
13--- git.orig/gst-libs/gst/vaapi/gstvaapiutils.h 2012-05-29 22:30:37.007259101 -0500
14+++ git/gst-libs/gst/vaapi/gstvaapiutils.h 2012-05-29 22:32:03.896466158 -0500
15@@ -23,7 +23,7 @@
16 #define GST_VAAPI_UTILS_H
17
18 #include "config.h"
19-#include <glib/gtypes.h>
20+#include <glib.h>
21
22 #ifdef GST_VAAPI_USE_OLD_VAAPI_0_29
23 # include <va.h>
24Index: git/gst-libs/gst/vaapi/gstvaapiutils_glx.h
25===================================================================
26--- git.orig/gst-libs/gst/vaapi/gstvaapiutils_glx.h 2012-05-29 22:30:47.497252785 -0500
27+++ git/gst-libs/gst/vaapi/gstvaapiutils_glx.h 2012-05-29 22:32:03.907085421 -0500
28@@ -27,7 +27,7 @@
29 #include <GL/glext.h>
30 #include <GL/glx.h>
31 #include <GL/glxext.h>
32-#include <glib/gtypes.h>
33+#include <glib.h>
34
35 #if GLX_GLXEXT_VERSION < 18
36 typedef void (*PFNGLXBINDTEXIMAGEEXTPROC)(Display *, GLXDrawable, int, const int *);
37Index: git/gst-libs/gst/vaapi/gstvaapiutils_x11.h
38===================================================================
39--- git.orig/gst-libs/gst/vaapi/gstvaapiutils_x11.h 2012-05-29 22:30:56.827305274 -0500
40+++ git/gst-libs/gst/vaapi/gstvaapiutils_x11.h 2012-05-29 22:32:03.916668015 -0500
41@@ -24,7 +24,7 @@
42
43 #include "config.h"
44 #include <X11/Xlib.h>
45-#include <glib/gtypes.h>
46+#include <glib.h>
47
48 void x11_trap_errors(void)
49 attribute_hidden;
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi_0.4.3.bb b/common/recipes-multimedia/gstreamer/gstreamer-vaapi_0.4.3.bb
new file mode 100644
index 00000000..93e0fbc5
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer-vaapi_0.4.3.bb
@@ -0,0 +1,24 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6LICENSE = "LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
8
9DEPENDS = "gstreamer gst-plugins-base gst-plugins-bad libva"
10
11SRC_URI = "http://www.freedesktop.org/software/vaapi/releases/${BPN}/${BPN}-${PV}.tar.bz2"
12SRC_URI[md5sum] = "7b1ede7193bc5a0aca921c490684f7b5"
13SRC_URI[sha256sum] = "68e0598456fe17085f6b8b1ce3da066322cc02c363955fb319776a5404d2b0da"
14
15inherit autotools pkgconfig gtk-doc
16
17PACKAGECONFIG ??= "${@base_contains("DISTRO_FEATURES", "x11", "x11", "", d)} \
18 ${@base_contains("DISTRO_FEATURES", "wayland", "wayland", "", d)}"
19PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr"
20PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland"
21
22FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
23FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
24FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb b/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb
deleted file mode 100644
index bdcf88ff..00000000
--- a/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6LICENSE = "LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
8
9DEPENDS = "gstreamer gst-plugins-base gst-plugins-bad libva"
10
11# 0.4.0 tag
12SRCREV = "329065546463512c8cc9c92c7f34510793ceb6dd"
13PV = "0.4.0+git${SRCPV}"
14PR = "r0"
15
16SRC_URI = "git://gitorious.org/vaapi/gstreamer-vaapi.git"
17
18SRC_URI[md5sum] = "729d75f21df79114a8c81d896489e5ad"
19SRC_URI[sha256sum] = "f1770c4537f1615701dbc845eee5732fbb1036b3acafbc7488e551fab334a31d"
20
21S = "${WORKDIR}/git"
22
23inherit autotools pkgconfig gtk-doc
24
25EXTRA_OECONF = "--disable-ffmpeg"
26
27do_configure_prepend() {
28 # DEBUG: Executing shell function do_configure
29 # ln: target `m4/' is not a directory: No such file or directory
30 # cp: cannot create regular file `m4/': Not a directory
31 # (should be fixed in autotools.bbclass)
32 mkdir --parents ${B}/m4
33}
34
35FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
36FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
37FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"