summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-12-15 13:59:57 +0000
committerCalifornia Sullivan <california.l.sullivan@intel.com>2016-12-15 10:27:18 -0800
commit466196fa2f619aa3d37ad6bfe13c11c72f910d16 (patch)
treee83ba8988f11c41ac195ce46159c5967834fd5cf /common/recipes-multimedia
parent04899c330de0560f128e259acf10ace42f1c1c1e (diff)
downloadmeta-intel-466196fa2f619aa3d37ad6bfe13c11c72f910d16.tar.gz
vaapi: remove as recipes moved to oe-core
libva and gstreamer-vaapi are now part of oe-core, so remove them. The package names were changed to reflect the naming scheme, so update the machine configurations to follow. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'common/recipes-multimedia')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_1.8.2.bb6
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi.inc36
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch43
-rw-r--r--common/recipes-multimedia/libva/libva_1.7.2.bb49
4 files changed, 0 insertions, 134 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_1.8.2.bb b/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_1.8.2.bb
deleted file mode 100644
index 3343baeb..00000000
--- a/common/recipes-multimedia/gstreamer/gstreamer-vaapi-1.0_1.8.2.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1require gstreamer-vaapi.inc
2
3DEPENDS += "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
4
5SRC_URI[md5sum] = "5683e0e950160f6a4b5bcd47176baad0"
6SRC_URI[sha256sum] = "5479e86f593d80c00bbd4a43b16b2027cb935412a2bb22c9ba4ac085627a9229"
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi.inc b/common/recipes-multimedia/gstreamer/gstreamer-vaapi.inc
deleted file mode 100644
index 6dea9cfc..00000000
--- a/common/recipes-multimedia/gstreamer/gstreamer-vaapi.inc
+++ /dev/null
@@ -1,36 +0,0 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6REALPN = "gstreamer-vaapi"
7FILESPATH = "${@base_set_filespath(["${FILE_DIRNAME}/${REALPN}", "${FILE_DIRNAME}/${REALPN}"], d)}"
8
9LICENSE = "LGPLv2.1+"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
11
12DEPENDS = "libva"
13
14SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz \
15 "
16
17S = "${WORKDIR}/${REALPN}-${PV}"
18
19inherit autotools pkgconfig gtk-doc
20
21PACKAGES =+ "${PN}-tests"
22
23PACKAGECONFIG ??= "drm \
24 ${@bb.utils.contains("DISTRO_FEATURES", "opengl x11", "glx", "", d)} \
25 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "wayland", "", d)} \
26 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}"
27
28PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,udev libdrm"
29PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,virtual/mesa"
30PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland"
31PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender"
32
33FILES_${PN} += "${libdir}/gstreamer-*/*.so"
34FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug"
35FILES_${PN}-dev += "${libdir}/gstreamer-*/*.la ${libdir}/gstreamer-*/*.a"
36FILES_${PN}-tests = "${bindir}/*"
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch b/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch
deleted file mode 100644
index d7def3a0..00000000
--- a/common/recipes-multimedia/gstreamer/gstreamer-vaapi/install-tests.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 2791dfde0de0abe8100fa833dfe1a9c2e74c2629 Mon Sep 17 00:00:00 2001
2From: Jianxun Zhang <jianxun.zhang@linux.intel.com>
3Date: Thu, 21 Jan 2016 16:25:44 -0800
4Subject: [PATCH] Install tests
5
6This patch is updated for 0.6.1
7
8Upstream-Status: Inappropriate
9
10Signed-off-by: Jianxun Zhang <jianxun.zhang@linux.intel.com>
11---
12 tests/Makefile.am | 6 +++---
13 1 file changed, 3 insertions(+), 3 deletions(-)
14
15diff --git a/tests/Makefile.am b/tests/Makefile.am
16index 3637d92..7cc6a97 100644
17--- a/tests/Makefile.am
18+++ b/tests/Makefile.am
19@@ -1,4 +1,4 @@
20-noinst_PROGRAMS = \
21+bin_PROGRAMS = \
22 simple-decoder \
23 test-decode \
24 test-display \
25@@ -9,13 +9,13 @@ noinst_PROGRAMS = \
26 $(NULL)
27
28 if USE_ENCODERS
29-noinst_PROGRAMS += \
30+bin_PROGRAMS += \
31 simple-encoder \
32 $(NULL)
33 endif
34
35 if USE_GLX
36-noinst_PROGRAMS += \
37+bin_PROGRAMS += \
38 test-textures \
39 $(NULL)
40 endif
41--
421.9.1
43
diff --git a/common/recipes-multimedia/libva/libva_1.7.2.bb b/common/recipes-multimedia/libva/libva_1.7.2.bb
deleted file mode 100644
index d72074db..00000000
--- a/common/recipes-multimedia/libva/libva_1.7.2.bb
+++ /dev/null
@@ -1,49 +0,0 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "http://www.freedesktop.org/wiki/Software/vaapi"
14BUGTRACKER = "https://bugs.freedesktop.org"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "http://www.freedesktop.org/software/vaapi/releases/libva/${BP}.tar.bz2"
21
22SRC_URI[md5sum] = "77d30af5a4bfaec6dddc2bdcbbd92ef5"
23SRC_URI[sha256sum] = "5dd61cf16a5648b680e6146a58064e93be11bf4e65a9e4e30f1e9cb8ecfa2c13"
24
25DEPENDS = "libdrm virtual/mesa virtual/libgles1 virtual/libgles2 virtual/egl"
26
27inherit autotools pkgconfig
28
29EXTRA_OECONF = "--disable-dummy-driver"
30
31PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)} \
32 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "wayland", "", d)}"
33PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
34PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland"
35
36PACKAGES =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl ${PN}-wayland"
37
38RDEPENDS_${PN}-tpi =+ "${PN}"
39RDEPENDS_${PN}-x11 =+ "${PN}"
40RDEPENDS_${PN}-glx =+ "${PN}-x11"
41RDEPENDS_${PN}-egl =+ "${PN}-x11"
42
43FILES_${PN}-dbg += "${libdir}/dri/.debug"
44
45FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
46FILES_${PN}-tpi =+ "${libdir}/libva-tpi*${SOLIBS}"
47FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
48FILES_${PN}-egl =+ "${libdir}/libva-egl*${SOLIBS}"
49FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"