diff options
author | Tom Zanussi <tom.zanussi@intel.com> | 2011-11-26 15:42:54 -0600 |
---|---|---|
committer | Tom Zanussi <tom.zanussi@intel.com> | 2011-12-01 22:20:52 -0600 |
commit | f76f51534d43328aa0101ede0b67402ba36cbe58 (patch) | |
tree | 08a993297fff963fec90b08839e880bd03067901 /common/recipes-multimedia/libva | |
parent | a5e14b926154ea2b737b469e9ade918bbf59af5e (diff) | |
download | meta-intel-f76f51534d43328aa0101ede0b67402ba36cbe58.tar.gz |
libva: upgrade to 1.0.12 and factor out common settings
EMGD 1.8 requires libva-1.0.12, so upgrade to that version, and we
don't actually need the 1.0.10 recipe, so remove it.
This also adds -dbg and -dev packaging fixes to fix QA problems,
removes some unnecessary settings, updates checksums, etc.
Also create and use a common libva.inc, as we'll soon be adding a more
updated version of libva to the current version.
Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-multimedia/libva')
-rw-r--r-- | common/recipes-multimedia/libva/libva.inc (renamed from common/recipes-multimedia/libva/libva_1.0.10.bb) | 19 | ||||
-rw-r--r-- | common/recipes-multimedia/libva/libva_1.0.12.bb | 8 |
2 files changed, 19 insertions, 8 deletions
diff --git a/common/recipes-multimedia/libva/libva_1.0.10.bb b/common/recipes-multimedia/libva/libva.inc index 0cd0444d..93b3caec 100644 --- a/common/recipes-multimedia/libva/libva_1.0.10.bb +++ b/common/recipes-multimedia/libva/libva.inc | |||
@@ -17,21 +17,24 @@ SECTION = "x11" | |||
17 | LICENSE = "MIT" | 17 | LICENSE = "MIT" |
18 | LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f" | 18 | LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f" |
19 | 19 | ||
20 | PR = "r1" | 20 | INC_PR = "r0" |
21 | 21 | ||
22 | DEPENDS = "libxext libxfixes libdrm" | 22 | DEPENDS = "libxext libxfixes libdrm" |
23 | 23 | ||
24 | SRC_URI = "http://cgit.freedesktop.org/libva/snapshot/libva-${PV}.tar.bz2" | ||
25 | |||
26 | SRC_URI[md5sum] = "959de03d47654adab855e10bff614df3" | ||
27 | SRC_URI[sha256sum] = "05f757f0043dce9f753d354d15e0cb772b1240cc9d29d26bbb5526285a203693" | ||
28 | |||
29 | inherit autotools pkgconfig | 24 | inherit autotools pkgconfig |
30 | 25 | ||
31 | LEAD_SONAME = "libva.so" | ||
32 | |||
33 | PACKAGES =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl" | 26 | PACKAGES =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl" |
27 | PACKAGES =+ "${PN}-x11-dev ${PN}-tpi-dev ${PN}-glx-dev ${PN}-egl-dev" | ||
28 | |||
34 | RDEPENDS_${PN} =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl" | 29 | RDEPENDS_${PN} =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl" |
30 | |||
31 | FILES_${PN}-dbg += "${libdir}/dri/.debug" | ||
32 | FILES_${PN} += "${libdir}/dri" | ||
33 | |||
34 | FILES_${PN}-x11-dev =+ "${libdir}/libva-x11.so" | ||
35 | FILES_${PN}-tpi-dev =+ "${libdir}/libva-tpi.so" | ||
36 | FILES_${PN}-glx-dev =+ "${libdir}/libva-glx.so" | ||
37 | FILES_${PN}-egl-dev =+ "${libdir}/libva-egl.so" | ||
35 | FILES_${PN}-x11 =+ "${libdir}/libva-x11.*" | 38 | FILES_${PN}-x11 =+ "${libdir}/libva-x11.*" |
36 | FILES_${PN}-tpi =+ "${libdir}/libva-tpi.*" | 39 | FILES_${PN}-tpi =+ "${libdir}/libva-tpi.*" |
37 | FILES_${PN}-glx =+ "${libdir}/libva-glx.*" | 40 | FILES_${PN}-glx =+ "${libdir}/libva-glx.*" |
diff --git a/common/recipes-multimedia/libva/libva_1.0.12.bb b/common/recipes-multimedia/libva/libva_1.0.12.bb new file mode 100644 index 00000000..490e60f8 --- /dev/null +++ b/common/recipes-multimedia/libva/libva_1.0.12.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | require libva.inc | ||
2 | |||
3 | PR = "${INC_PR}.0" | ||
4 | |||
5 | SRC_URI = "http://cgit.freedesktop.org/libva/snapshot/libva-${PV}.tar.bz2" | ||
6 | |||
7 | SRC_URI[md5sum] = "84408a0746a63b8cf308dc7b9f2451cf" | ||
8 | SRC_URI[sha256sum] = "e80aae68fc78d237d046be6525d333f072fd57fe4f4d8f981e869703ebfee8f5" | ||