diff options
author | Ross Burton <ross.burton@intel.com> | 2015-02-27 18:00:32 +0000 |
---|---|---|
committer | Darren Hart <dvhart@linux.intel.com> | 2015-02-27 10:11:59 -0800 |
commit | 9c4a574e556ed43e75704f28889daa53fa896ba4 (patch) | |
tree | 4e3391bd7e47451507a6c08477eef4487d1b3418 /common/recipes-multimedia/libva/libva.inc | |
parent | de2894e7e32e3dfe9b1ac8930207c0a35ad89029 (diff) | |
download | meta-intel-9c4a574e556ed43e75704f28889daa53fa896ba4.tar.gz |
libva: merge recipe and .inc
As there's just a single libva recipe now having .bb and .inc split only
complicates packaging.
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'common/recipes-multimedia/libva/libva.inc')
-rw-r--r-- | common/recipes-multimedia/libva/libva.inc | 46 |
1 files changed, 0 insertions, 46 deletions
diff --git a/common/recipes-multimedia/libva/libva.inc b/common/recipes-multimedia/libva/libva.inc deleted file mode 100644 index f7f50024..00000000 --- a/common/recipes-multimedia/libva/libva.inc +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | SUMMARY = "Video Acceleration (VA) API for Linux" | ||
2 | DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \ | ||
3 | and API specification which enables and provides access to graphics \ | ||
4 | hardware (GPU) acceleration for video processing on Linux and UNIX \ | ||
5 | based operating systems. Accelerated processing includes video \ | ||
6 | decoding, video encoding, subpicture blending and rendering. The \ | ||
7 | specification was originally designed by Intel for its GMA (Graphics \ | ||
8 | Media Accelerator) series of GPU hardware, the API is however not \ | ||
9 | limited to GPUs or Intel specific hardware, as other hardware and \ | ||
10 | manufacturers can also freely use this API for hardware accelerated \ | ||
11 | video decoding." | ||
12 | |||
13 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/vaapi" | ||
14 | BUGTRACKER = "https://bugs.freedesktop.org" | ||
15 | |||
16 | SECTION = "x11" | ||
17 | LICENSE = "MIT" | ||
18 | LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f" | ||
19 | |||
20 | INC_PR = "r1" | ||
21 | |||
22 | DEPENDS = "libdrm virtual/mesa virtual/libgles1 virtual/libgles2 virtual/egl" | ||
23 | |||
24 | inherit autotools-brokensep pkgconfig | ||
25 | |||
26 | EXTRA_OECONF = "--disable-dummy-driver" | ||
27 | |||
28 | PACKAGECONFIG ??= "${@base_contains("DISTRO_FEATURES", "x11", "x11", "", d)} \ | ||
29 | ${@base_contains("DISTRO_FEATURES", "wayland", "wayland", "", d)}" | ||
30 | PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes" | ||
31 | PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland" | ||
32 | |||
33 | PACKAGES =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl ${PN}-wayland" | ||
34 | |||
35 | RDEPENDS_${PN}-tpi =+ "${PN}" | ||
36 | RDEPENDS_${PN}-x11 =+ "${PN}" | ||
37 | RDEPENDS_${PN}-glx =+ "${PN}-x11" | ||
38 | RDEPENDS_${PN}-egl =+ "${PN}-x11" | ||
39 | |||
40 | FILES_${PN}-dbg += "${libdir}/dri/.debug" | ||
41 | |||
42 | FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}" | ||
43 | FILES_${PN}-tpi =+ "${libdir}/libva-tpi*${SOLIBS}" | ||
44 | FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}" | ||
45 | FILES_${PN}-egl =+ "${libdir}/libva-egl*${SOLIBS}" | ||
46 | FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}" | ||