summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/libva/libva-intel-driver_1.2.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-11-13 15:15:47 +0000
committerTom Zanussi <tom.zanussi@intel.com>2013-11-14 15:56:27 -0600
commit678e42bdcc31b6f416c9885fc90498a4700276cd (patch)
treef9f3c827e72628596bd3daac7bc4d14b00868460 /common/recipes-multimedia/libva/libva-intel-driver_1.2.1.bb
parenta9f02ffa711079ba835af431802e0a3b7b006904 (diff)
downloadmeta-intel-678e42bdcc31b6f416c9885fc90498a4700276cd.tar.gz
libva-intel-driver: upgrade to 1.2.1
Remove the .bb/.inc split as we're only supporting one version. Add PACKAGECONFIG for X11 and Wayland features. Add patch to fix compile error in builds with Wayland but without X11. Drop the workaround patch, isn't relevant for released hardware. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-multimedia/libva/libva-intel-driver_1.2.1.bb')
-rw-r--r--common/recipes-multimedia/libva/libva-intel-driver_1.2.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/common/recipes-multimedia/libva/libva-intel-driver_1.2.1.bb b/common/recipes-multimedia/libva/libva-intel-driver_1.2.1.bb
new file mode 100644
index 00000000..f90ad502
--- /dev/null
+++ b/common/recipes-multimedia/libva/libva-intel-driver_1.2.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "VA driver for Intel G45 & HD Graphics family"
2DESCRIPTION = "libva-driver-intel is the VA-API implementation \
3for Intel G45 chipsets and Intel HD Graphics for Intel Core \
4processor family."
5
6HOMEPAGE = "http://www.freedesktop.org/wiki/Software/vaapi"
7BUGTRACKER = "https://bugs.freedesktop.org"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
11
12COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
13
14DEPENDS = "libva libdrm"
15
16SRC_URI = "http://www.freedesktop.org/software/vaapi/releases/${BPN}/${BPN}-${PV}.tar.bz2"
17SRC_URI += "file://wayland-include.patch"
18
19SRC_URI[md5sum] = "8248d224d35c9544777f1c7250f581b2"
20SRC_URI[sha256sum] = "5c6917c961b1de7f0d5ea3a6feac8eeec098d8aff6cdf2bca44e9b3083515186"
21
22inherit autotools pkgconfig
23
24PACKAGECONFIG ??= "${@base_contains("DISTRO_FEATURES", "x11", "x11", "", d)} \
25 ${@base_contains("DISTRO_FEATURES", "opengl wayland", "wayland", "", d)}"
26PACKAGECONFIG[x11] = "--enable-x11,--disable-x11"
27PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland virtual/egl"
28
29FILES_${PN} += "${libdir}/dri/*.so"
30FILES_${PN}-dev += "${libdir}/dri/*.la"
31FILES_${PN}-dbg += "${libdir}/dri/.debug"