summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-10-18 23:41:38 +0100
committerTom Zanussi <tom.zanussi@intel.com>2013-11-04 16:47:59 -0600
commitbfb34edf5a9e00b3a15cf7b9bb2630d3d749006f (patch)
tree006c5cd878ebf2aef278f63faffc3e56d3f20576 /common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb
parentebf255564f43b193d7d6426f79ada9b143790867 (diff)
downloadmeta-intel-bfb34edf5a9e00b3a15cf7b9bb2630d3d749006f.tar.gz
gstreamer-vaapi: upgrade to 0.4.3
Use tarballs instead of git tags (upstream git means using submodules, which are tricky). Also use PACKAGECONFIG to respect x11/wayland DISTRO_FEATURES. Delete glib-includes.patch, as it wasn't being used. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb37
1 files changed, 0 insertions, 37 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb b/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb
deleted file mode 100644
index bdcf88ff..00000000
--- a/common/recipes-multimedia/gstreamer/gstreamer-vaapi_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6LICENSE = "LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
8
9DEPENDS = "gstreamer gst-plugins-base gst-plugins-bad libva"
10
11# 0.4.0 tag
12SRCREV = "329065546463512c8cc9c92c7f34510793ceb6dd"
13PV = "0.4.0+git${SRCPV}"
14PR = "r0"
15
16SRC_URI = "git://gitorious.org/vaapi/gstreamer-vaapi.git"
17
18SRC_URI[md5sum] = "729d75f21df79114a8c81d896489e5ad"
19SRC_URI[sha256sum] = "f1770c4537f1615701dbc845eee5732fbb1036b3acafbc7488e551fab334a31d"
20
21S = "${WORKDIR}/git"
22
23inherit autotools pkgconfig gtk-doc
24
25EXTRA_OECONF = "--disable-ffmpeg"
26
27do_configure_prepend() {
28 # DEBUG: Executing shell function do_configure
29 # ln: target `m4/' is not a directory: No such file or directory
30 # cp: cannot create regular file `m4/': Not a directory
31 # (should be fixed in autotools.bbclass)
32 mkdir --parents ${B}/m4
33}
34
35FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
36FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
37FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"