summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/gstreamer/gst-va-intel.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-07-19 14:19:52 -0500
committerTom Zanussi <tom.zanussi@intel.com>2012-08-30 16:28:10 -0500
commit756571750b0449335ef01279ce10609099b8a8e1 (patch)
tree7954f602ddf977e512dbdc75ce11e69130e675cf /common/recipes-multimedia/gstreamer/gst-va-intel.bb
parent1ef6cd26cabe46d9ceaa0d257bf7d690a0592e7c (diff)
downloadmeta-intel-756571750b0449335ef01279ce10609099b8a8e1.tar.gz
meta-intel: add va-impl-intel MACHINE_FEATURE
Add a new va-impl-intel MACHINE_FEATURE to explicitly choose intel video acceleration, rather than have it as the fallthrough default, so that anything that wants to specify something different locally doesn't get unwanted components. Also rename the gst-va-mixvideo feature to va-impl-mixvideo match and since it isn't only concerned with gst. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-multimedia/gstreamer/gst-va-intel.bb')
-rw-r--r--common/recipes-multimedia/gstreamer/gst-va-intel.bb16
1 files changed, 13 insertions, 3 deletions
diff --git a/common/recipes-multimedia/gstreamer/gst-va-intel.bb b/common/recipes-multimedia/gstreamer/gst-va-intel.bb
index 17cb7c8d..516e5f19 100644
--- a/common/recipes-multimedia/gstreamer/gst-va-intel.bb
+++ b/common/recipes-multimedia/gstreamer/gst-va-intel.bb
@@ -4,10 +4,16 @@ DEPENDS = "gst-meta-base"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \ 4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
5 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 5 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6 6
7PR = "r0" 7PR = "r1"
8 8
9VAAPI_IMPL = "${@base_contains('MACHINE_FEATURES', 'gst-va-mixvideo', 'gst-va-mixvideo-vaapi', \ 9def map_gst_vaapi(d):
10 'gst-va-intel-vaapi', d)}" 10 if base_contains('MACHINE_FEATURES', 'va-impl-mixvideo', "1", "0", d) == "1":
11 return "gst-va-mixvideo-vaapi"
12 if base_contains('MACHINE_FEATURES', 'va-impl-intel', "1", "0", d) == "1":
13 return "gst-va-intel-vaapi"
14 return ""
15
16VAAPI_IMPL = "${@map_gst_vaapi(d)}"
11 17
12PACKAGES = "\ 18PACKAGES = "\
13 gst-va-intel \ 19 gst-va-intel \
@@ -32,10 +38,14 @@ RDEPENDS_gst-va-intel-video = "\
32 gst-plugins-good-isomp4 \ 38 gst-plugins-good-isomp4 \
33 " 39 "
34 40
41# The gstreamer-vaapi package contains the vaapi implementation
42#
35RDEPENDS_gst-va-intel-vaapi = "\ 43RDEPENDS_gst-va-intel-vaapi = "\
36 gstreamer-vaapi \ 44 gstreamer-vaapi \
37 " 45 "
38 46
47# The emgd driver contains the vaapi implementation
48#
39RDEPENDS_gst-va-mixvideo-vaapi = "\ 49RDEPENDS_gst-va-mixvideo-vaapi = "\
40 emgd-driver-bin \ 50 emgd-driver-bin \
41 " 51 "