summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-08-25 14:46:12 -0700
committerSaul Wold <sgw@linux.intel.com>2015-08-28 14:25:29 -0700
commite226a9f68052035bd2a4330e0ef2feeb467f7fb2 (patch)
treefd2b3f260f4629f6fdd26b3945cece8715ee170a /common/recipes-kernel
parent4c0f5f8975671e83df5b243e71ef92654ac344c8 (diff)
downloadmeta-intel-e226a9f68052035bd2a4330e0ef2feeb467f7fb2.tar.gz
linux-yocto_4.1: Update to 4.1.6 stable kernel
This SRCREV update pulls in the 4.1.6 Stable kernel and adds the coretemp thermal driver to intel-common. It also cleans up the quark BSP and adds the quark specific thermal code. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend18
1 files changed, 9 insertions, 9 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
index 6830e3b9..f248b31d 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -2,29 +2,29 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4 4
5LINUX_VERSION_core2-32-intel-common = "4.1.2" 5LINUX_VERSION_core2-32-intel-common = "4.1.6"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7KMACHINE_core2-32-intel-common = "intel-core2-32" 7KMACHINE_core2-32-intel-common = "intel-core2-32"
8KBRANCH_core2-32-intel-common = "standard/base" 8KBRANCH_core2-32-intel-common = "standard/base"
9SRCREV_meta_core2-32-intel-common ?= "45393dd54f5ad77d43014c407c2b3520da42f427" 9SRCREV_meta_core2-32-intel-common ?= "429f9e2ff0649b8c9341345622545d874d5e303a"
10SRCREV_machine_core2-32-intel-common ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f" 10SRCREV_machine_core2-32-intel-common ?= "59b8c4f5e8ddb9c33c62fff22204fe2b0d8c703e"
11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
12 12
13LINUX_VERSION_corei7-64-intel-common = "4.1.2" 13LINUX_VERSION_corei7-64-intel-common = "4.1.6"
14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64" 15KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16KBRANCH_corei7-64-intel-common = "standard/base" 16KBRANCH_corei7-64-intel-common = "standard/base"
17SRCREV_meta_corei7-64-intel-common ?= "45393dd54f5ad77d43014c407c2b3520da42f427" 17SRCREV_meta_corei7-64-intel-common ?= "429f9e2ff0649b8c9341345622545d874d5e303a"
18SRCREV_machine_corei7-64-intel-common ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f" 18SRCREV_machine_corei7-64-intel-common ?= "59b8c4f5e8ddb9c33c62fff22204fe2b0d8c703e"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
20 20
21# Quark / X1000 BSP Info 21# Quark / X1000 BSP Info
22LINUX_VERSION_i586-nlp-32-intel-common = "4.1.2" 22LINUX_VERSION_i586-nlp-32-intel-common = "4.1.6"
23COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" 23COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
24KMACHINE_i586-nlp-32-intel-common = "intel-quark" 24KMACHINE_i586-nlp-32-intel-common = "intel-quark"
25KBRANCH_i586-nlp-32-intel-common = "standard/base" 25KBRANCH_i586-nlp-32-intel-common = "standard/base"
26SRCREV_meta_i586-nlp-32-intel-common ?= "45393dd54f5ad77d43014c407c2b3520da42f427" 26SRCREV_meta_i586-nlp-32-intel-common ?= "429f9e2ff0649b8c9341345622545d874d5e303a"
27SRCREV_machine_i586-nlp-32-intel-common ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f" 27SRCREV_machine_i586-nlp-32-intel-common ?= "59b8c4f5e8ddb9c33c62fff22204fe2b0d8c703e"
28KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" 28KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
29 29
30 30