summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
authorMikko Ylinen <mikko.ylinen@linux.intel.com>2017-08-15 18:19:10 +0300
committerSaul Wold <sgw@linux.intel.com>2017-08-15 14:03:06 -0700
commitdacbc86ef39e7545ac266ba1d3a7bf6338fd0ad4 (patch)
tree1afd3c8b716edb217ed32220547806a954ea5dfd /common/recipes-kernel
parent92ce2459bc82b9ecdf9623c3008b7a8f427506dd (diff)
downloadmeta-intel-dacbc86ef39e7545ac266ba1d3a7bf6338fd0ad4.tar.gz
linux-firmware: install iwlwifi LinuxCore driver firmware blobs
meta-intel maintains a recipe that installs iwlwifi's LinuxCore wifi driver releases. For some iwfwifi LinuxCore supported wireless chips, the best/latest firmware blobs are found in the iwlwifi's linux-firmware.git fork. See: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/core_release This bbappend fetches the -31.ucode (currently, for Intel Wireless 8260 only!) that is the best match for the iwlwifi LinuxCore release built. The bbappend can later be extended to pull in firmware blobs for other chips too. Fixes: [YOCTO #11925] Signed-off-by: Mikko Ylinen <mikko.ylinen@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/linux-firmware/linux-firmware_%.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux-firmware/linux-firmware_%.bbappend b/common/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
new file mode 100644
index 00000000..50836ee1
--- /dev/null
+++ b/common/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
@@ -0,0 +1,21 @@
1# meta-intel maintains a recipe that installs iwlwifi's LinuxCore wifi
2# driver releases. For some iwfwifi LinuxCore supported wireless chips, the
3# best/latest firmware blobs are found in the iwlwifi's linux-firmware.git fork.
4#
5# See: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/core_release
6#
7# This bbappend fetches the -31.ucode (currently, for Intel Wireless 8260
8# only!) that is the best match for the iwlwifi LinuxCore release built.
9#
10# Note: keep these in sync when updating the iwlwifi_git.bb LinuxCore
11# versions.
12
13SRC_URI_append = " https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git/plain/iwlwifi-8000C-31.ucode;name=iwlwifi-8260-31"
14
15SRC_URI[iwlwifi-8260-31.md5sum] = "428a84a780bbe864a7af6a6734c4b529"
16SRC_URI[iwlwifi-8260-31.sha256sum] = "5a337c52f9d7a7cb5cb0a13c93232f4de742ed0debef757d68231bdb55455406"
17
18do_install_append() {
19 # Copy the iwlwifi/LinuxCore required ucode for Intel Wireless 8260
20 cp ${WORKDIR}/iwlwifi-8000C-31.ucode ${D}/${nonarch_base_libdir}/firmware/
21}