summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-12-07 16:05:03 -0800
committerSaul Wold <sgw@linux.intel.com>2015-12-08 12:27:40 -0800
commit6cc51b58060c18e14e5c5b331596d469b4b364af (patch)
treee7ba1324d0d65836cdb0bbe8c544acfad4be4a76 /common/recipes-kernel
parent1ce13b3d39b2da79916e3a175cee6baa507290f1 (diff)
downloadmeta-intel-6cc51b58060c18e14e5c5b331596d469b4b364af.tar.gz
linux-yocto: Update to 4.1.13
Refactor meta-data slightly so they are sharing common information via SRCREV_META_INTEL_COMMON, SRCREV_MACHINE_INTEL_COMMON, ... Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend34
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend29
2 files changed, 37 insertions, 26 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
index a0e2ef42..c63474a6 100644
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
@@ -1,25 +1,31 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_core2-32-intel-common = "4.1.8" 3LINUX_VERSION_INTEL_COMMON = "4.1.13"
4SRCREV_META_INTEL_COMMON ?= "30c4b4bd79c5d774de6dcf23d0deab554e31f3d4"
5SRCREV_MACHINE_INTEL_COMMON ?= "44fb75fd4731d1169725ac49a305e0913440974f"
6
7KBRANCH_INTEL_COMMON = "standard/preempt-rt/base"
8
9LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
4COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 10COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
5SRCREV_meta_core2-32-intel-common = "aed902160251d69cc28d1e69a4f692e8ea8fa13b"
6SRCREV_machine_core2-32-intel-common = "f7e4bbfef684e29b1257eaf2d7f534b38e2e1b1e"
7KMACHINE_core2-32-intel-common = "intel-core2-32" 11KMACHINE_core2-32-intel-common = "intel-core2-32"
8KBRANCH_core2-32-intel-common = "standard/preempt-rt/base" 12KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
13SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
14SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
9KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 15KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10 16
11LINUX_VERSION_corei7-64-intel-common = "4.1.8" 17LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
12COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 18COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
13SRCREV_meta_corei7-64-intel-common = "aed902160251d69cc28d1e69a4f692e8ea8fa13b"
14SRCREV_machine_corei7-64-intel-common = "f7e4bbfef684e29b1257eaf2d7f534b38e2e1b1e"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64" 19KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16KBRANCH_corei7-64-intel-common = "standard/preempt-rt/base" 20KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}"
21SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
22SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
17KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 23KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
18 24
19LINUX_VERSION_i586-nlp-32-intel-common = "4.1.8" 25LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
20COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" 26COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
21SRCREV_meta_i586-nlp-32-intel-common = "aed902160251d69cc28d1e69a4f692e8ea8fa13b" 27KMACHINE_i586-nlp-32-intel-common = "intel-quark"
22SRCREV_machine_i586-nlp-32-intel-common = "f7e4bbfef684e29b1257eaf2d7f534b38e2e1b1e" 28KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
23KMACHINE_i586-nlp-32-intel-common = "intel-corei7-64" 29SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
24KBRANCH_i586-nlp-32-intel-common = "standard/preempt-rt/base" 30SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
25KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 31KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
index c8d24934..1d66b959 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -1,30 +1,35 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_INTEL_COMMON = "4.1.13"
4SRCREV_META_INTEL_COMMON = "30c4b4bd79c5d774de6dcf23d0deab554e31f3d4"
5SRCREV_MACHINE_INTEL_COMMON = "c22dc676d6d560d0b2a316283a514d65d2a510e4"
6
7KBRANCH_INTEL_COMMON = "standard/base"
3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 8KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4 9
5LINUX_VERSION_core2-32-intel-common = "4.1.8" 10LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 11COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7KMACHINE_core2-32-intel-common = "intel-core2-32" 12KMACHINE_core2-32-intel-common = "intel-core2-32"
8KBRANCH_core2-32-intel-common = "standard/base" 13KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
9SRCREV_meta_core2-32-intel-common ?= "cf9ab7112dd8b7fe02739a76e24ba32e87b91306" 14SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
10SRCREV_machine_core2-32-intel-common ?= "dbe692d91c8e55d1430f2c45fd578c8e4e71e482" 15SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 16KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
12 17
13LINUX_VERSION_corei7-64-intel-common = "4.1.8" 18LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 19COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64" 20KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16KBRANCH_corei7-64-intel-common = "standard/base" 21KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}"
17SRCREV_meta_corei7-64-intel-common ?= "cf9ab7112dd8b7fe02739a76e24ba32e87b91306" 22SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
18SRCREV_machine_corei7-64-intel-common ?= "dbe692d91c8e55d1430f2c45fd578c8e4e71e482" 23SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 24KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
20 25
21# Quark / X1000 BSP Info 26# Quark / X1000 BSP Info
22LINUX_VERSION_i586-nlp-32-intel-common = "4.1.8" 27LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
23COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" 28COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
24KMACHINE_i586-nlp-32-intel-common = "intel-quark" 29KMACHINE_i586-nlp-32-intel-common = "intel-quark"
25KBRANCH_i586-nlp-32-intel-common = "standard/base" 30KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
26SRCREV_meta_i586-nlp-32-intel-common ?= "cf9ab7112dd8b7fe02739a76e24ba32e87b91306" 31SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
27SRCREV_machine_i586-nlp-32-intel-common ?= "dbe692d91c8e55d1430f2c45fd578c8e4e71e482" 32SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
28KERNEL_FEATURES_append_i586-nlp-32-intel-common = "" 33KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
29 34
30 35