diff options
author | California Sullivan <california.l.sullivan@intel.com> | 2016-07-07 18:50:02 -0700 |
---|---|---|
committer | Tom Zanussi <tom.zanussi@linux.intel.com> | 2016-07-07 18:20:28 -0500 |
commit | 9bb462266ef2dcb2d2fbcc43cb069c8e5574bb42 (patch) | |
tree | a9aa59a5163d5d41f88c86e3fc4a3ce7949125b4 /common/recipes-kernel | |
parent | 8b0a89027ae8954faac51ac0cff856e05d305594 (diff) | |
download | meta-intel-9bb462266ef2dcb2d2fbcc43cb069c8e5574bb42.tar.gz |
linux-yocto/4.1: Update SRCREVs for better Apollo Lake support
From linux-yocto-4.1:
0abef8c x86: Fix Apollo Lake Watchdog address in PMC driver
f8571ea Merge branch 'standard/base' into standard/intel/base
75d56a1 device property: Avoid potential dereferences of invalid pointers
2700b65 device property: convert to use match_string() helper
fef2c68 lib/string: introduce match_string() helper
3ce862d device property: fix for a case of use-after-free
cdb0343 device property: fwnode->secondary may contain ERR_PTR(-ENODEV)
24bd70f xhci: harden xhci_find_next_ext_cap against device removal
3e54ee9 xhci: rework xhci extended capability list parsing functions
038f1ab xhci: parse xhci protocol speed ID list for usb 3.1 usage
b53d7c6 Merge branch 'standard/base' into standard/intel/base
18a2d70 extcon: Redefine the unique id of supported external connectors without 'enum extcon' type
0ded526 extcon: Remove optional print_name() function pointer of extcon_dev
a181fb1 extcon: Update the prototype of extcon_register_notifier() with enum extcon
4cce716 extcon: Use capital letter for the name of external connectors
1079fdb extcon: Use the unique id for external connector instead of string
425f259 extcon: Remove the optional name of extcon device
e371084 extcon: adc-jack: Remove the unneeded num_cables field
79663c6 extcon: Alter MHL-TA cable name to TA cable name
f2c1e58 extcon: Unify the dock device names on max8997/77693
349e77e extcon: Unify the jig cable names on rt8973 and max14577/77693/77843
035ddfe extcon: Fix the checkpatch warning and minor coding style issue
7611d1c extcon: Add extcon_get_edev_name() API to get the extcon device name
8833fdc extcon: Modify the device name as extcon[X] for sysfs
f3a7d2b extcon: Add manufactor name of each extcon device
f4b51de mmc: core: Add functions for SDIO to hold re-tuning
cb4d597 scsi_lib: add extended information to MEDIA_CHANGE
3ce85da libata: enable atapi_an by default
e30fdb9 EDAC: pnd2_edac: Add new EDAC driver for Intel SoC platforms
1bf50d4 mfd: lpc_ich: Add support for Intel Apollo Lake SoC
d7f8df6 mfd: lpc_ich: Add support for SPI serial flash host controller
9331cca spi-nor: Add support for Intel SPI serial flash controller
47389b7 Merge branch 'standard/base' into standard/intel/base
6ea8af4 mtd: spi-nor: add driver for NXP SPI Flash Interface (SPIFI)
3a5603c x86: Add missing Makefile entry so Sideband driver actually builds
446a452 PCI: Add runtime PM support for PCIe ports
f99bb2a ACPI / hotplug / PCI: Runtime resume bridge before rescan
3dfb410 PCI: Power on bridges before scanning new devices
68a139f PCI: Put PCIe ports into D3 during suspend
5b227a3 PCI / PM: Tune down retryable runtime suspend error messages
f13548f platform:x86 Remove Monitor MWAIT feature dependency
03716fc PCI: Don't clear d3cold_allowed for PCIe ports
From yocto-kernel-cache:
48837d8 mei.cfg: mei driver is no longer in staging
48a3d45 fsl-ls10xx: add kernel meta scc/cfg data
0845ec7 mei.cfg: Add CONFIG_INTEL_MEI_TXE=m
886dacb features/thermal: enable Intel powerclamp driver
b0e1c17 firmware: remove invalid +CONFIG*
Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r-- | common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend | 4 | ||||
-rw-r--r-- | common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend | 4 | ||||
-rw-r--r-- | common/recipes-kernel/linux/linux-yocto_4.1.bbappend | 4 |
3 files changed, 6 insertions, 6 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend index fd5eff12..07cd1f19 100644 --- a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend +++ b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend | |||
@@ -1,8 +1,8 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | LINUX_VERSION_INTEL_COMMON = "4.1.26" | 3 | LINUX_VERSION_INTEL_COMMON = "4.1.26" |
4 | SRCREV_META_INTEL_COMMON ?= "e978d15367ec69788c4a10d1e2a65bfa626c5d8c" | 4 | SRCREV_META_INTEL_COMMON ?= "48837d8ef0a7fcf781e735e58a7f58976443f8c0" |
5 | SRCREV_MACHINE_INTEL_COMMON ?= "243226a1f494304001dd5f878f8ab74fce34a945" | 5 | SRCREV_MACHINE_INTEL_COMMON ?= "12fb1640fd5df81530b35ccdd754aebe8d63351f" |
6 | 6 | ||
7 | KBRANCH_INTEL_COMMON = "standard/preempt-rt/intel/base" | 7 | KBRANCH_INTEL_COMMON = "standard/preempt-rt/intel/base" |
8 | 8 | ||
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend index 47c8f48a..74543b86 100644 --- a/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend +++ b/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend | |||
@@ -1,8 +1,8 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | #LINUX_VERSION_i586-nlp-32-intel-common = "4.1.26" | 3 | #LINUX_VERSION_i586-nlp-32-intel-common = "4.1.26" |
4 | SRCREV_meta_i586-nlp-32-intel-common = "e978d15367ec69788c4a10d1e2a65bfa626c5d8c" | 4 | SRCREV_meta_i586-nlp-32-intel-common = "48837d8ef0a7fcf781e735e58a7f58976443f8c0" |
5 | SRCREV_machine_i586-nlp-32-intel-common = "9f166e918f63dd7214ad0388d64709d33f2a14a3" | 5 | SRCREV_machine_i586-nlp-32-intel-common = "75d56a13f86fc48002e4a3f9ed60546db30432b7" |
6 | 6 | ||
7 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" | 7 | COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" |
8 | KBRANCH_i586-nlp-32-intel-common = "standard/tiny/intel/base" | 8 | KBRANCH_i586-nlp-32-intel-common = "standard/tiny/intel/base" |
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend index 52cadf85..fca19a8c 100644 --- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend +++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend | |||
@@ -1,8 +1,8 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | LINUX_VERSION_INTEL_COMMON = "4.1.26" | 3 | LINUX_VERSION_INTEL_COMMON = "4.1.26" |
4 | SRCREV_META_INTEL_COMMON = "e978d15367ec69788c4a10d1e2a65bfa626c5d8c" | 4 | SRCREV_META_INTEL_COMMON = "48837d8ef0a7fcf781e735e58a7f58976443f8c0" |
5 | SRCREV_MACHINE_INTEL_COMMON = "248ceac02f35f4b10a3462a3219ada429b32f628" | 5 | SRCREV_MACHINE_INTEL_COMMON = "0abef8c8dfcf527cb4c8476c3ac9d095589b18cb" |
6 | 6 | ||
7 | KBRANCH_INTEL_COMMON = "standard/intel/base" | 7 | KBRANCH_INTEL_COMMON = "standard/intel/base" |
8 | KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" | 8 | KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" |