summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2014-09-17 17:33:30 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-09-30 10:01:01 -0500
commite1b6652d829ee72dcec0edd68269e6df0a495747 (patch)
treebb381c01ea0876d5a475da1ff7fe7065685ffe4e /common/recipes-kernel
parentc0f64c88cabcd37fb028e88671d3cd8557e5a7d4 (diff)
downloadmeta-intel-e1b6652d829ee72dcec0edd68269e6df0a495747.tar.gz
linux-yocto: Add linux-yocto_3.17.bbappend
Extend the linux-yocto_3.17 recipe from the oe-core layer for the use of meta-intel BSPs. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.17.bbappend28
1 files changed, 28 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_3.17.bbappend b/common/recipes-kernel/linux/linux-yocto_3.17.bbappend
new file mode 100644
index 00000000..3dcadf61
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto_3.17.bbappend
@@ -0,0 +1,28 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3# For NUC
4KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
5
6LINUX_VERSION_core2-32-intel-common = "3.17-rc4"
7COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
8SRCREV_meta_core2-32-intel-common = "7df849fc7eba54765368e26634341dbe6e2ad161"
9SRCREV_machine_core2-32-intel-common = "1a3939eb747a635b23b4234f785795c52dce72a8"
10KMACHINE_core2-32-intel-common = "intel-core2-32"
11KBRANCH_core2-32-intel-common = "standard/base"
12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
13
14LINUX_VERSION_corei7-64-intel-common = "3.17-rc4"
15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
16SRCREV_meta_corei7-64-intel-common = "7df849fc7eba54765368e26634341dbe6e2ad161"
17SRCREV_machine_corei7-64-intel-common = "1a3939eb747a635b23b4234f785795c52dce72a8"
18KMACHINE_corei7-64-intel-common = "intel-corei7-64"
19KBRANCH_corei7-64-intel-common = "standard/base"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
21
22# For Crystalforest and Romley
23KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
24KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
25
26# For FRI2, NUC
27KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
28KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"