summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2014-06-17 17:47:44 -0700
committerTom Zanussi <tom.zanussi@intel.com>2014-06-23 09:47:47 -0500
commitbf97ece14e1444e3898798599a4299ad1c7556c6 (patch)
tree55a3d8408685d9339c87e1ea98b09395cbd474ad /common/recipes-kernel
parent6aa0c6a6a75f6a4c2fda8e59be1212464307c69a (diff)
downloadmeta-intel-bf97ece14e1444e3898798599a4299ad1c7556c6.tar.gz
linux-yocto recipes: fix use of module_autoload_* vars
oecore/poky layer changed, needing replacement of all the module_autoload_* recipe variables by the KERNEL_MODULE_AUTOLOAD variable. This fixes these kind of buildtime errors coming from the meta-intel layer: ERROR: KERNEL_MODULE_AUTOLOAD has replaced module_autoload_iwlwifi, please replace it! Addresses bug: [YOCTO #6460] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-dev.bbappend4
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.10.bbappend4
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.14.bbappend4
3 files changed, 6 insertions, 6 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
index b8c06df0..71e40957 100644
--- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -19,7 +19,7 @@ KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}
19# default SRCREV is set and linux-yocto-dev is the preferred provider. 19# default SRCREV is set and linux-yocto-dev is the preferred provider.
20 20
21# For Crystalforest and Romley 21# For Crystalforest and Romley
22module_autoload_uio = "uio" 22KERNEL_MODULE_AUTOLOAD += "uio"
23 23
24# For FRI2 24# For FRI2
25module_autoload_iwlwifi = "iwlwifi" 25KERNEL_MODULE_AUTOLOAD += "iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 3bb53432..bbce8f4a 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -21,7 +21,7 @@ KBRANCH_corei7-64-intel-common = "standard/base"
21KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 21KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
22 22
23# For Crystalforest and Romley 23# For Crystalforest and Romley
24module_autoload_uio = "uio" 24KERNEL_MODULE_AUTOLOAD += "uio"
25 25
26# For FRI2, NUC 26# For FRI2, NUC
27module_autoload_iwlwifi = "iwlwifi" 27KERNEL_MODULE_AUTOLOAD += "iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
index 3c34f095..139c1f0a 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -20,7 +20,7 @@ KBRANCH_corei7-64-intel-common = "standard/base"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
21 21
22# For Crystalforest and Romley 22# For Crystalforest and Romley
23module_autoload_uio = "uio" 23KERNEL_MODULE_AUTOLOAD += "uio"
24 24
25# For FRI2, NUC 25# For FRI2, NUC
26module_autoload_iwlwifi = "iwlwifi" 26KERNEL_MODULE_AUTOLOAD += "iwlwifi"