summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-05-15 19:52:24 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-05-21 09:21:59 -0500
commit0331a7df42e43928d133d204047371164f2e0174 (patch)
tree6e255d9a67d6d883adf5b311ec5a09e7efc532d3 /common/recipes-kernel
parentcb0f5fbd614ec6a9052539416734ca1ab26a1892 (diff)
downloadmeta-intel-0331a7df42e43928d133d204047371164f2e0174.tar.gz
intel-common: Add linux-yocto 3.14-rt recipe
Since linux-yocto-rt_3.14 didn't make it into the 1.6 release of oe-core, we need the .bb here. Still separate the .bbappend here to keep it as close as possible to the master branch, where the .bb is available in oe-core. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_3.14.bb26
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend17
2 files changed, 43 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_3.14.bb b/common/recipes-kernel/linux/linux-yocto-rt_3.14.bb
new file mode 100644
index 00000000..d96870bf
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto-rt_3.14.bb
@@ -0,0 +1,26 @@
1require recipes-kernel/linux/linux-yocto.inc
2
3KBRANCH = "standard/preempt-rt/base"
4KBRANCH_qemuppc = "standard/preempt-rt/qemuppc"
5
6SRCREV_machine ?= "d31cfd2232d5f8287cad3fdeac4f8cc6b372a729"
7SRCREV_meta ?= "11e091dc40c53af6ea08ce491ae50fbb1b0b6377"
8
9SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
10
11LINUX_VERSION ?= "3.14.2"
12
13PV = "${LINUX_VERSION}+git${SRCPV}"
14
15KMETA = "meta"
16
17LINUX_KERNEL_TYPE = "preempt-rt"
18
19COMPATIBLE_MACHINE = "(qemux86|qemux86-64)"
20
21# Functionality flags
22KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
23KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
24KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
25KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
26KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend
new file mode 100644
index 00000000..c991b4d1
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto-rt_3.14.bbappend
@@ -0,0 +1,17 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3LINUX_VERSION_core2-32-intel-common = "3.14.2"
4COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
5SRCREV_meta_core2-32-intel-common = "11e091dc40c53af6ea08ce491ae50fbb1b0b6377"
6SRCREV_machine_core2-32-intel-common = "d31cfd2232d5f8287cad3fdeac4f8cc6b372a729"
7KMACHINE_core2-32-intel-common = "intel-core2-32"
8KBRANCH_core2-32-intel-common = "standard/preempt-rt/base"
9KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10
11LINUX_VERSION_corei7-64-intel-common = "3.14.2"
12COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
13SRCREV_meta_corei7-64-intel-common = "11e091dc40c53af6ea08ce491ae50fbb1b0b6377"
14SRCREV_machine_corei7-64-intel-common = "d31cfd2232d5f8287cad3fdeac4f8cc6b372a729"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16KBRANCH_corei7-64-intel-common = "standard/preempt-rt/base"
17KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"