summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2016-03-17 17:19:03 -0700
committerSaul Wold <sgw@linux.intel.com>2016-03-17 22:20:59 -0700
commit3f637d34c917214378b838a359ca9fcacf49d9ee (patch)
tree2a144d9874026d6c292c34708cd70912e8110a89 /common/recipes-kernel
parentc0f64623df35902644be90b38c2deaba1931c806 (diff)
downloadmeta-intel-3f637d34c917214378b838a359ca9fcacf49d9ee.tar.gz
linux-yocto/4.4: Galileo updates and explicitly set CONFIG_FTRACE=y
Integrate several patches for Galileo support. Explicitly set CONFIG_FTRACE=y in the yocto-kernel-cache, as the ktype refactoring update caused it to no longer be set by default in standard. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend4
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend4
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.4.bbappend4
3 files changed, 6 insertions, 6 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
index bb512801..2c0f94e3 100644
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
@@ -1,8 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_INTEL_COMMON = "4.4.3" 3LINUX_VERSION_INTEL_COMMON = "4.4.3"
4SRCREV_META_INTEL_COMMON ?= "da47accec6c17c22cecf064be1da29b5bf3d7583" 4SRCREV_META_INTEL_COMMON ?= "e0cf18471a271cd057538e9d33fa01a7669ff76f"
5SRCREV_MACHINE_INTEL_COMMON ?= "853991833cc5140ca25450e81bf6b822d537a6ac" 5SRCREV_MACHINE_INTEL_COMMON ?= "dfa88200087a7ef73741383c05c14ff2f3978947"
6 6
7KBRANCH_INTEL_COMMON = "standard/preempt-rt" 7KBRANCH_INTEL_COMMON = "standard/preempt-rt"
8 8
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
index 491408ac..0dd9c8fa 100644
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
@@ -1,8 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3#LINUX_VERSION_i586-nlp-32-intel-common = "4.4.3" 3#LINUX_VERSION_i586-nlp-32-intel-common = "4.4.3"
4SRCREV_meta-i586-nlp-32-intel-common = "da47accec6c17c22cecf064be1da29b5bf3d7583" 4SRCREV_meta-i586-nlp-32-intel-common = "e0cf18471a271cd057538e9d33fa01a7669ff76f"
5SRCREV_machine-i586-nlp-32-intel-common = "ff4c4ef15b51f45b9106d71bf1f62fe7c02e63c2" 5SRCREV_machine-i586-nlp-32-intel-common = "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
6 6
7COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" 7COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
8KBRANCH_i586-nlp-32-intel-common = "standard/tiny/common-pc" 8KBRANCH_i586-nlp-32-intel-common = "standard/tiny/common-pc"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
index eff68a5a..1a4a0536 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
@@ -1,8 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_INTEL_COMMON = "4.4.3" 3LINUX_VERSION_INTEL_COMMON = "4.4.3"
4SRCREV_META_INTEL_COMMON = "da47accec6c17c22cecf064be1da29b5bf3d7583" 4SRCREV_META_INTEL_COMMON = "e0cf18471a271cd057538e9d33fa01a7669ff76f"
5SRCREV_MACHINE_INTEL_COMMON = "ff4c4ef15b51f45b9106d71bf1f62fe7c02e63c2" 5SRCREV_MACHINE_INTEL_COMMON = "3d2455f9da30f923c6bd69014fad4cc4ea738be6"
6 6
7KBRANCH_INTEL_COMMON = "standard/base" 7KBRANCH_INTEL_COMMON = "standard/base"
8KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 8KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"