summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2016-11-15 16:59:33 -0800
committerSaul Wold <sgw@linux.intel.com>2016-11-16 09:12:26 -0800
commit10feb903cfd69e6699f81a668b7128120e396dbf (patch)
treef440b52cd5b4f8ee40455d566c916d690ac92358 /common/recipes-kernel
parent82104c818ff7e00d5574fd90654dbb5fbc410847 (diff)
downloadmeta-intel-10feb903cfd69e6699f81a668b7128120e396dbf.tar.gz
linux-yocto: Remove mei from KERNEL_FEATURES
The kernel cache was refactored and this feature was moved, and is now included in intel-common BSPs by default. This option is no longer necessary and by pointing to the wrong location was breaking builds. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-dev.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend1
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.4.bbappend1
3 files changed, 0 insertions, 4 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
index 9a1b5d0c..3b1382c6 100644
--- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,7 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4
5COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 3COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
6KMACHINE_core2-32-intel-common = "intel-core2-32" 4KMACHINE_core2-32-intel-common = "intel-core2-32"
7KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 5KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
index fae684ee..5215af56 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -5,7 +5,6 @@ SRCREV_META_INTEL_COMMON = "3c3197e65b6f2f5514853c1fe78ae8ffc131b02c"
5SRCREV_MACHINE_INTEL_COMMON = "302ef0123fb9033f4059b6d722ed8b226ba36e99" 5SRCREV_MACHINE_INTEL_COMMON = "302ef0123fb9033f4059b6d722ed8b226ba36e99"
6 6
7KBRANCH_INTEL_COMMON = "standard/intel/base" 7KBRANCH_INTEL_COMMON = "standard/intel/base"
8KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
9 8
10LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}" 9LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
11COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 10COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
diff --git a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
index 288ed901..fca62311 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
@@ -5,7 +5,6 @@ SRCREV_META_INTEL_COMMON = "3030330b066a33ce21164a8b30d0503cf9f68e5b"
5SRCREV_MACHINE_INTEL_COMMON = "6729daf8d803e7a21c31e5fd68ff1069456448ad" 5SRCREV_MACHINE_INTEL_COMMON = "6729daf8d803e7a21c31e5fd68ff1069456448ad"
6 6
7KBRANCH_INTEL_COMMON = "standard/intel/base" 7KBRANCH_INTEL_COMMON = "standard/intel/base"
8KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
9 8
10LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}" 9LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
11COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 10COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"