summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2016-09-22 12:50:47 -0700
committerSaul Wold <sgw@linux.intel.com>2016-09-23 10:04:16 -0700
commit7cceac01e1e0a5745600403d9b334babb76dc8ce (patch)
tree37b6d16b4ca081b65c6d7311b06d012cc5493e67 /common/recipes-kernel/linux
parent31abb97302ec665e076204fade3e23b395844380 (diff)
downloadmeta-intel-7cceac01e1e0a5745600403d9b334babb76dc8ce.tar.gz
linux-yocto*: Fix LINUX_VERSION variables
I was checking the kver file to update the LINUX_VERSION variable. At the time of the last SRCREV update the kver files were incorrect. With the kernel_version_sanity_check function added to oe-core, the incorrect PV becomes a build error. Fix this by updating the LINUX_VERSION variables in each linux-yocto recipe to their correct value. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel/linux')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend2
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.4.bbappend2
6 files changed, 6 insertions, 6 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
index 7a25ca82..17e514f3 100644
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_INTEL_COMMON = "4.1.30" 3LINUX_VERSION_INTEL_COMMON = "4.1.31"
4SRCREV_META_INTEL_COMMON ?= "cf6d9876629270e8ed99541db252840291d03f5a" 4SRCREV_META_INTEL_COMMON ?= "cf6d9876629270e8ed99541db252840291d03f5a"
5SRCREV_MACHINE_INTEL_COMMON ?= "7370721cafa5a420bef873f3b0547f1135aba0db" 5SRCREV_MACHINE_INTEL_COMMON ?= "7370721cafa5a420bef873f3b0547f1135aba0db"
6 6
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
index b2289413..8ec80fb5 100644
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_INTEL_COMMON = "4.4.18" 3LINUX_VERSION_INTEL_COMMON = "4.4.20"
4SRCREV_META_INTEL_COMMON ?= "59290c5f6192da2eccf478d37a8f9f88134822b3" 4SRCREV_META_INTEL_COMMON ?= "59290c5f6192da2eccf478d37a8f9f88134822b3"
5SRCREV_MACHINE_INTEL_COMMON ?= "b5e21aa9882c815fe522810cce2e3c86e20ffee2" 5SRCREV_MACHINE_INTEL_COMMON ?= "b5e21aa9882c815fe522810cce2e3c86e20ffee2"
6 6
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
index 56af19fb..a488e87c 100644
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-tiny_4.1.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3#LINUX_VERSION_i586-nlp-32-intel-common = "4.1.30" 3LINUX_VERSION_i586-nlp-32-intel-common = "4.1.31"
4SRCREV_meta_i586-nlp-32-intel-common = "cf6d9876629270e8ed99541db252840291d03f5a" 4SRCREV_meta_i586-nlp-32-intel-common = "cf6d9876629270e8ed99541db252840291d03f5a"
5SRCREV_machine_i586-nlp-32-intel-common = "488286187ea5bda2e35730e5593f040c9f0f34d1" 5SRCREV_machine_i586-nlp-32-intel-common = "488286187ea5bda2e35730e5593f040c9f0f34d1"
6 6
diff --git a/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
index 31dbb1ce..31402ea2 100644
--- a/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3#LINUX_VERSION_i586-nlp-32-intel-common = "4.4.18" 3LINUX_VERSION_i586-nlp-32-intel-common = "4.4.20"
4SRCREV_meta_i586-nlp-32-intel-common = "59290c5f6192da2eccf478d37a8f9f88134822b3" 4SRCREV_meta_i586-nlp-32-intel-common = "59290c5f6192da2eccf478d37a8f9f88134822b3"
5SRCREV_machine_i586-nlp-32-intel-common = "2cbbf10c66383c0c052708686ab005a9f9dc442c" 5SRCREV_machine_i586-nlp-32-intel-common = "2cbbf10c66383c0c052708686ab005a9f9dc442c"
6 6
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
index 5b38d939..c093ebdc 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_INTEL_COMMON = "4.1.30" 3LINUX_VERSION_INTEL_COMMON = "4.1.31"
4SRCREV_META_INTEL_COMMON = "cf6d9876629270e8ed99541db252840291d03f5a" 4SRCREV_META_INTEL_COMMON = "cf6d9876629270e8ed99541db252840291d03f5a"
5SRCREV_MACHINE_INTEL_COMMON = "518132aeea9ac874fd4c51cd02b137704e00c3ae" 5SRCREV_MACHINE_INTEL_COMMON = "518132aeea9ac874fd4c51cd02b137704e00c3ae"
6 6
diff --git a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
index 10abfb55..f7f3c5a2 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_INTEL_COMMON = "4.4.18" 3LINUX_VERSION_INTEL_COMMON = "4.4.20"
4SRCREV_META_INTEL_COMMON = "59290c5f6192da2eccf478d37a8f9f88134822b3" 4SRCREV_META_INTEL_COMMON = "59290c5f6192da2eccf478d37a8f9f88134822b3"
5SRCREV_MACHINE_INTEL_COMMON = "94e5bb30eaf8a880a6c82b64a497d8b4a855d138" 5SRCREV_MACHINE_INTEL_COMMON = "94e5bb30eaf8a880a6c82b64a497d8b4a855d138"
6 6