summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-06-26 14:22:10 +0000
committerDarren Hart <dvhart@linux.intel.com>2014-06-26 14:22:10 +0000
commit05dd98cf5c117a8bdd566d36d20a84fff20e8cc3 (patch)
treeeedb3499fcc3881c9c3bd8275e8f0269fbc3b3cd /common/recipes-kernel/linux
parent76f529881208811e314dba1478cc3a70abf3160f (diff)
downloadmeta-intel-05dd98cf5c117a8bdd566d36d20a84fff20e8cc3.tar.gz
linux-yocto: Make KERNEL_MODULE_AUTOLOAD machine specific
BSP linux-yocto bbappend files should make all variable updates with machine-specific overrides. As it stands, building qemux86 with meta-intel in BBLAYERS will add uio and iwlwifi to KERNEL_MODULES_AUTOLOAD. This corrects that. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel/linux')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-dev.bbappend8
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.10.bbappend6
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.14.bbappend6
3 files changed, 13 insertions, 7 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-dev.bbappend b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
index 71e40957..ddc1c4a4 100644
--- a/common/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -19,7 +19,9 @@ KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}
19# default SRCREV is set and linux-yocto-dev is the preferred provider. 19# default SRCREV is set and linux-yocto-dev is the preferred provider.
20 20
21# For Crystalforest and Romley 21# For Crystalforest and Romley
22KERNEL_MODULE_AUTOLOAD += "uio" 22KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "uio"
23KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "uio"
23 24
24# For FRI2 25# For FRI2, NUC
25KERNEL_MODULE_AUTOLOAD += "iwlwifi" 26KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "iwlwifi"
27KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
index bbce8f4a..a142e5be 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -21,7 +21,9 @@ KBRANCH_corei7-64-intel-common = "standard/base"
21KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 21KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
22 22
23# For Crystalforest and Romley 23# For Crystalforest and Romley
24KERNEL_MODULE_AUTOLOAD += "uio" 24KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "uio"
25KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "uio"
25 26
26# For FRI2, NUC 27# For FRI2, NUC
27KERNEL_MODULE_AUTOLOAD += "iwlwifi" 28KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "iwlwifi"
29KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "iwlwifi"
diff --git a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
index 139c1f0a..a0ca5fcd 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -20,7 +20,9 @@ KBRANCH_corei7-64-intel-common = "standard/base"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
21 21
22# For Crystalforest and Romley 22# For Crystalforest and Romley
23KERNEL_MODULE_AUTOLOAD += "uio" 23KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "uio"
24KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "uio"
24 25
25# For FRI2, NUC 26# For FRI2, NUC
26KERNEL_MODULE_AUTOLOAD += "iwlwifi" 27KERNEL_MODULE_AUTOLOAD_core2-32-intel-common += "iwlwifi"
28KERNEL_MODULE_AUTOLOAD_corei7-64-intel-common += "iwlwifi"