summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2016-05-27 13:18:49 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2016-05-27 17:35:08 -0500
commit4ca61fd1d4f4049da238aefc783d83c8e6d5e8cd (patch)
tree386a877ee1c925175c6924c25f96864c0ba04f1a /common/recipes-kernel/linux/linux-yocto_4.4.bbappend
parent945240490a3512167f09bd9080fbadd918d23469 (diff)
downloadmeta-intel-4ca61fd1d4f4049da238aefc783d83c8e6d5e8cd.tar.gz
linux-yocto/4.4: Update SRCREVs to bring in Broxton related backports
From linux-yocto-4.4: 53e8410 mmc: mmc: Fix partition switch timeout for some eMMCs 1256894 mmc: mmc: Attempt to flush cache before reset 9c0fffe mmc: sdhci: Remove SDHCI_SDR104_NEEDS_TUNING fa337a1 mmc: core: Do regular power cycle when lacking eMMC HW reset support 54179f6 pinctrl: intel: make the high level interrupt working f170df4 device property: convert to use match_string() helper c33ead2 lib/string: introduce match_string() helper 1390667 device property: fix for a case of use-after-free 2a293fe device property: fwnode->secondary may contain ERR_PTR(-ENODEV) 755ae5c mmc: make MAN_BKOPS_EN message a debug 029f8f5 intel_idle: add BXT support 917289e intel_idle: Add SKX support 687143a intel_idle: Clean up all registered devices on exit. 631b661 intel_idle: Propagate hot plug errors. 2b207b2 intel_idle: Don't overreact to a cpuidle registration failure. 241e122 intel_idle: Setup the timer broadcast only on successful driver load. 0eed236 intel_idle: Avoid a double free of the per-CPU data. 6f64cec intel_idle: Fix dangling registration on error path. 422dc7a intel_idle: Fix deallocation order on the driver exit path. a953265 intel_idle: Remove redundant initialization calls. a728676 intel_idle: Fix a helper function's return value. 65f8c73 intel_idle: remove useless return from void function. daa2ee8 mfd: intel-lpss: Pass I2C configuration via properties on BXT 23afcc8 intel_idle: Support for Intel Xeon Phi Processor x200 Product Family a45b2ec ACPI / gpio: Add irq_type when a GPIO is used as an interrupt 30172f0 ACPI: Rename acpi_gsi_get_irq_type to acpi_dev_get_irq_type and export symbol 8036200 Revert "gpio: revert get() to non-errorprogating behaviour" 122f7f8 device property: avoid allocations of 0 length b73aa97 device property: the secondary fwnode needs to depend on the primary af345ee mfd: intel-lpss: Pass HSUART configuration via properties f7234c3 mfd: intel-lpss: Pass SDA hold time to I2C host controller driver 5a828d0 mfd: intel-lpss: Add support for passing device properties d23cd03 mfd: core: propagate device properties to sub devices drivers c7c3fd1 driver core: platform: Add support for built-in device properties 8472af8 device property: Take a copy of the property set 4cbb58f device property: Fallback to secondary fwnode if primary misses the property f9d3687 device property: return -EINVAL when property isn't found in ACPI 2164c0d device property: improve readability of macros 8fd19e9 device property: helper macros for property entry creation a037877 device property: keep single value inplace 77c4d97 device property: refactor built-in properties support 0968394 device property: rename helper functions d79c4dd device property: always check for fwnode type 2e4ae64 gpiolib: do not allow to insert an empty gpiochip 0c01b85 pwm: lpss: Rework the sequence of programming PWM_SW_UPDATE e5d9413 pwm: lpss: Update PWM setting for Broxton b76110b pwm: lpss: Remove ->free() callback From yocto-kernel-cache: 3a5f494 Revert "common-pc*: Have *-standard BSPs use standard/intel" Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto_4.4.bbappend')
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.4.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
index 5f38d7ff..2f534396 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.4.bbappend
@@ -1,8 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_INTEL_COMMON = "4.4.11" 3LINUX_VERSION_INTEL_COMMON = "4.4.11"
4SRCREV_META_INTEL_COMMON = "1465ac389f22979618852aa04298049cfdd5dcb4" 4SRCREV_META_INTEL_COMMON = "3a5f494784591e01f0ae7ab748e8190582c16e8c"
5SRCREV_MACHINE_INTEL_COMMON = "628bf627561c6285d99fb978e11d4c15fc29324b" 5SRCREV_MACHINE_INTEL_COMMON = "53e84104c5e68eb468823dd0d262a64623d01a55"
6 6
7KBRANCH_INTEL_COMMON = "standard/intel" 7KBRANCH_INTEL_COMMON = "standard/intel"
8KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 8KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"