summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
diff options
context:
space:
mode:
authorGeorge Nita <george.nita@enea.com>2015-08-20 05:12:04 +0200
committerGeorge Nita <george.nita@enea.com>2015-08-20 05:12:04 +0200
commit52b57c5f39a041f0a05aac092d142050845734c9 (patch)
tree620d8cc0cd1e2d82403e4445e58c2ea0801e62fc /common/recipes-kernel/linux/linux-yocto_4.1.bbappend
parentaedac614e462f2c11ea7ce7de02e5aa2267a3e3b (diff)
parentadc8064908409d29b9f6a7f0710be400769807af (diff)
downloadmeta-intel-52b57c5f39a041f0a05aac092d142050845734c9.tar.gz
Merge remote-tracking branch 'origin/master' into master-enea
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto_4.1.bbappend')
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend37
1 files changed, 37 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
new file mode 100644
index 00000000..6830e3b9
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -0,0 +1,37 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4
5LINUX_VERSION_core2-32-intel-common = "4.1.2"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
7KMACHINE_core2-32-intel-common = "intel-core2-32"
8KBRANCH_core2-32-intel-common = "standard/base"
9SRCREV_meta_core2-32-intel-common ?= "45393dd54f5ad77d43014c407c2b3520da42f427"
10SRCREV_machine_core2-32-intel-common ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
11KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
12
13LINUX_VERSION_corei7-64-intel-common = "4.1.2"
14COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16KBRANCH_corei7-64-intel-common = "standard/base"
17SRCREV_meta_corei7-64-intel-common ?= "45393dd54f5ad77d43014c407c2b3520da42f427"
18SRCREV_machine_corei7-64-intel-common ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
20
21# Quark / X1000 BSP Info
22LINUX_VERSION_i586-nlp-32-intel-common = "4.1.2"
23COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
24KMACHINE_i586-nlp-32-intel-common = "intel-quark"
25KBRANCH_i586-nlp-32-intel-common = "standard/base"
26SRCREV_meta_i586-nlp-32-intel-common ?= "45393dd54f5ad77d43014c407c2b3520da42f427"
27SRCREV_machine_i586-nlp-32-intel-common ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
28KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
29
30
31# For Crystalforest and Romley
32KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
33KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
34
35# For FRI2, NUC
36KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
37KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"