summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
diff options
context:
space:
mode:
authorRebecca Chang Swee Fun <rebecca.swee.fun.chang@intel.com>2016-09-20 13:02:19 +0800
committerSaul Wold <sgw@linux.intel.com>2016-09-21 07:44:43 -0700
commit3957e4d5044d16170ef52cc7ec6ea513c968137b (patch)
treef145260830f8c4496c3ad45087c2b0ebed0f0eef /common/recipes-kernel/linux/linux-yocto_4.1.bbappend
parent3335bb8e4941ce89c65b6128537fc7133dd5dbd3 (diff)
downloadmeta-intel-3957e4d5044d16170ef52cc7ec6ea513c968137b.tar.gz
linux-yocto_4.1: include ssp audio configuration fragment
Leaf Hill BSP supports 2 types of audio configurations. By defaults, BSP will compiled legacy HD-Audio feature, users can set "AUDIO_FEATURES" in local.conf when they want Intel SSP Audio feature. Both audio features are unique and they are mutually exclusive. AUDIO_FEATURES = "ssp" in local.conf is up to users to turn on or off depends on their use cases. Signed-off-by: Rebecca Chang Swee Fun <rebecca.swee.fun.chang@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto_4.1.bbappend')
-rw-r--r--common/recipes-kernel/linux/linux-yocto_4.1.bbappend4
1 files changed, 3 insertions, 1 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
index 23b6828e..48445d8b 100644
--- a/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_4.1.bbappend
@@ -1,6 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc" 3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4KERNEL_FEATURES_LEAFHILL_AUDIO += "bsp/leafhill/snd_ssp_intel.scc"
4 5
5LINUX_VERSION_core2-32-intel-common = "4.1.26" 6LINUX_VERSION_core2-32-intel-common = "4.1.26"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 7COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
@@ -16,7 +17,8 @@ KMACHINE_corei7-64-intel-common = "${@bb.utils.contains('KERNEL_FEATURES', 'leaf
16KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', 'standard/intel/4.1.27/leaf-hill', 'standard/intel/base', d)}" 17KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', 'standard/intel/4.1.27/leaf-hill', 'standard/intel/base', d)}"
17SRCREV_meta_corei7-64-intel-common ?= "68b5089eeffb5878a990d9eb418407c8e18a6f37" 18SRCREV_meta_corei7-64-intel-common ?= "68b5089eeffb5878a990d9eb418407c8e18a6f37"
18SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', '41fc98f785ad56f0df1b85ac039bd5e391697842', '9195020e5747fba069c19996fab079931584a7fb', d)}" 19SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('KERNEL_FEATURES', 'leafhill', '41fc98f785ad56f0df1b85ac039bd5e391697842', '9195020e5747fba069c19996fab079931584a7fb', d)}"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON} \
21 ${@bb.utils.contains('AUDIO_FEATURES', 'ssp', '${KERNEL_FEATURES_LEAFHILL_AUDIO}', '', d)}"
20 22
21# Quark / X1000 BSP Info 23# Quark / X1000 BSP Info
22LINUX_VERSION_i586-nlp-32-intel-common = "4.1.26" 24LINUX_VERSION_i586-nlp-32-intel-common = "4.1.26"