summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-yocto_3.19.bbappend
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2015-02-20 13:30:05 -0800
committerDarren Hart <dvhart@linux.intel.com>2015-02-20 13:32:33 -0800
commitd7cb7ecc0a3be4fd16e8ccc84a71b2fd490806b4 (patch)
tree0f228e78ee91ddd9c02b8cc4dc273b22e1e23308 /common/recipes-kernel/linux/linux-yocto_3.19.bbappend
parent2acbe8c61bb70406447c9b2085883979fdb1ed43 (diff)
downloadmeta-intel-d7cb7ecc0a3be4fd16e8ccc84a71b2fd490806b4.tar.gz
linux-yocto-3.19: Add 3.19 bbappend for the Intel common BSPs
Add the 3.19 bbappend for the Intel common BSPs. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto_3.19.bbappend')
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.19.bbappend28
1 files changed, 28 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_3.19.bbappend b/common/recipes-kernel/linux/linux-yocto_3.19.bbappend
new file mode 100644
index 00000000..1ebadf33
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto_3.19.bbappend
@@ -0,0 +1,28 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3# For NUC
4KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
5
6LINUX_VERSION_core2-32-intel-common = "3.19.0"
7COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
8SRCREV_meta_core2-32-intel-common = "8897ef68b30e7426bc1d39895e71fb155d694974"
9SRCREV_machine_core2-32-intel-common = "43b9eced9ba8a57add36af07736344dcc383f711"
10KMACHINE_core2-32-intel-common = "intel-core2-32"
11KBRANCH_core2-32-intel-common = "standard/base"
12KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
13
14LINUX_VERSION_corei7-64-intel-common = "3.19.0"
15COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
16SRCREV_meta_corei7-64-intel-common = "8897ef68b30e7426bc1d39895e71fb155d694974"
17SRCREV_machine_corei7-64-intel-common = "43b9eced9ba8a57add36af07736344dcc383f711"
18KMACHINE_corei7-64-intel-common = "intel-corei7-64"
19KBRANCH_corei7-64-intel-common = "standard/base"
20KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
21
22# For Crystalforest and Romley
23KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
24KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
25
26# For FRI2, NUC
27KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
28KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"