summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-03-12 10:41:27 -0700
committerDarren Hart <dvhart@linux.intel.com>2014-03-12 14:51:00 -0700
commit09d485dcce6ed4b654abc0c8a630f1d36bc1a7d6 (patch)
tree0a4c98143b6ca294cd5d085d03590fb863c233df /common/recipes-kernel/linux/linux-yocto_3.10.bbappend
parentbf3ae602ad3f18f673fa6d268634fa4af8d4b2c9 (diff)
downloadmeta-intel-09d485dcce6ed4b654abc0c8a630f1d36bc1a7d6.tar.gz
linux-yocto: Remove redundant recipes
Remove all redundant linux-yocto recipes where the BSP is able to reuse the intel-common version. Update the common bbappends with the KERNEL_FEATURES and module_autoload* statements from the consolidated bbappends. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto_3.10.bbappend')
-rw-r--r--common/recipes-kernel/linux/linux-yocto_3.10.bbappend8
1 files changed, 7 insertions, 1 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
index e3ebd3ee..01e3f77b 100644
--- a/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,6 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3KERNEL_FEATURES_INTEL_COMMON = "" 3KERNEL_FEATURES_INTEL_COMMON += "features/amt/mei/mei.scc"
4 4
5#LINUX_VERSION_core2-32-intel-common = "3.10" 5#LINUX_VERSION_core2-32-intel-common = "3.10"
6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 6COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
@@ -17,3 +17,9 @@ COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64" 17KMACHINE_intel-corei7-64-intel-common = "intel-corei7-64"
18KBRANCH_intel-corei7-64-intel-common = "standard/base" 18KBRANCH_intel-corei7-64-intel-common = "standard/base"
19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 19KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
20
21# For Crystalforest and Romley
22module_autoload_uio = "uio"
23
24# For FRI2
25module_autoload_iwlwifi = "iwlwifi"