summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2016-01-21 10:41:28 -0800
committerSaul Wold <sgw@linux.intel.com>2016-02-22 14:53:15 -0800
commitfeb264f77373e8ca64d4e0bb1fd71e59ed983a90 (patch)
tree15e45be157f929191894f859b16174069b4df33f /common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
parent324918de4639be380cef04bdcfdb8bbdb4c221d5 (diff)
downloadmeta-intel-feb264f77373e8ca64d4e0bb1fd71e59ed983a90.tar.gz
linux-yocto: add bbappends for 4.4 kernels
These are necessary for the meta-intel BSPs to make use of the new kernel. The SRCREVs are pointing at kernel version 4.4.1 - the latest stable release. Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend31
1 files changed, 31 insertions, 0 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
new file mode 100644
index 00000000..37773091
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-yocto-rt_4.4.bbappend
@@ -0,0 +1,31 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3LINUX_VERSION_INTEL_COMMON = "4.4.1"
4SRCREV_META_INTEL_COMMON ?= "4940c6e551c1eea41a5dbc69a90b23d5f835fa5b"
5SRCREV_MACHINE_INTEL_COMMON ?= "b90e0f8ee29395bbeb1d4b1dc06d4a78063f2c36"
6
7KBRANCH_INTEL_COMMON = "standard/preempt-rt"
8
9LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
10COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
11KMACHINE_core2-32-intel-common = "intel-core2-32"
12KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
13SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
14SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
15KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
16
17LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
18COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
19KMACHINE_corei7-64-intel-common = "intel-corei7-64"
20KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}"
21SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
22SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
23KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
24
25LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
26COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
27KMACHINE_i586-nlp-32-intel-common = "intel-quark"
28KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
29SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
30SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
31KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""