summaryrefslogtreecommitdiffstats
path: root/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-12-07 16:05:03 -0800
committerSaul Wold <sgw@linux.intel.com>2015-12-08 12:27:40 -0800
commit6cc51b58060c18e14e5c5b331596d469b4b364af (patch)
treee7ba1324d0d65836cdb0bbe8c544acfad4be4a76 /common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
parent1ce13b3d39b2da79916e3a175cee6baa507290f1 (diff)
downloadmeta-intel-6cc51b58060c18e14e5c5b331596d469b4b364af.tar.gz
linux-yocto: Update to 4.1.13
Refactor meta-data slightly so they are sharing common information via SRCREV_META_INTEL_COMMON, SRCREV_MACHINE_INTEL_COMMON, ... Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend')
-rw-r--r--common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend34
1 files changed, 20 insertions, 14 deletions
diff --git a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
index a0e2ef42..c63474a6 100644
--- a/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
+++ b/common/recipes-kernel/linux/linux-yocto-rt_4.1.bbappend
@@ -1,25 +1,31 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3LINUX_VERSION_core2-32-intel-common = "4.1.8" 3LINUX_VERSION_INTEL_COMMON = "4.1.13"
4SRCREV_META_INTEL_COMMON ?= "30c4b4bd79c5d774de6dcf23d0deab554e31f3d4"
5SRCREV_MACHINE_INTEL_COMMON ?= "44fb75fd4731d1169725ac49a305e0913440974f"
6
7KBRANCH_INTEL_COMMON = "standard/preempt-rt/base"
8
9LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
4COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}" 10COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
5SRCREV_meta_core2-32-intel-common = "aed902160251d69cc28d1e69a4f692e8ea8fa13b"
6SRCREV_machine_core2-32-intel-common = "f7e4bbfef684e29b1257eaf2d7f534b38e2e1b1e"
7KMACHINE_core2-32-intel-common = "intel-core2-32" 11KMACHINE_core2-32-intel-common = "intel-core2-32"
8KBRANCH_core2-32-intel-common = "standard/preempt-rt/base" 12KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
13SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
14SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
9KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 15KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10 16
11LINUX_VERSION_corei7-64-intel-common = "4.1.8" 17LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
12COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}" 18COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
13SRCREV_meta_corei7-64-intel-common = "aed902160251d69cc28d1e69a4f692e8ea8fa13b"
14SRCREV_machine_corei7-64-intel-common = "f7e4bbfef684e29b1257eaf2d7f534b38e2e1b1e"
15KMACHINE_corei7-64-intel-common = "intel-corei7-64" 19KMACHINE_corei7-64-intel-common = "intel-corei7-64"
16KBRANCH_corei7-64-intel-common = "standard/preempt-rt/base" 20KBRANCH_corei7-64-intel-common = "${KBRANCH_INTEL_COMMON}"
21SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
22SRCREV_machine_corei7-64-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
17KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 23KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
18 24
19LINUX_VERSION_i586-nlp-32-intel-common = "4.1.8" 25LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
20COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}" 26COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
21SRCREV_meta_i586-nlp-32-intel-common = "aed902160251d69cc28d1e69a4f692e8ea8fa13b" 27KMACHINE_i586-nlp-32-intel-common = "intel-quark"
22SRCREV_machine_i586-nlp-32-intel-common = "f7e4bbfef684e29b1257eaf2d7f534b38e2e1b1e" 28KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
23KMACHINE_i586-nlp-32-intel-common = "intel-corei7-64" 29SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
24KBRANCH_i586-nlp-32-intel-common = "standard/preempt-rt/base" 30SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
25KERNEL_FEATURES_append_i586-nlp-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}" 31KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""