summaryrefslogtreecommitdiffstats
path: root/common/recipes-graphics
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2014-09-04 16:15:51 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-09-16 20:12:41 -0500
commit1796fac0f9baaa056e31559a3c6f5e5b0a8eb743 (patch)
tree756a906d3909124dde01159af11e31b0fa7eb197 /common/recipes-graphics
parentc939705c186388df1eb68341a207fb2c6ac95f66 (diff)
downloadmeta-intel-1796fac0f9baaa056e31559a3c6f5e5b0a8eb743.tar.gz
Remove the xserver-xorg-1.9.3 recipe and it's files
The xserver-xorg-1.9.3 recipe was needed only for the EMGD graphics driver. After removing the EMGD support from the meta-intel layer there is no need to keep this old recipe and it's files. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-graphics')
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3.inc20
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/crosscompile.patch22
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/fix_open_max_preprocessor_error.patch15
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/macro_tweak.patch30
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/nodolt.patch14
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/ptr-to-int-cast-fix.patch92
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/werror-address-fix.patch49
-rw-r--r--common/recipes-graphics/xorg-xserver/xserver-xorg_1.9.3.bb4
8 files changed, 0 insertions, 246 deletions
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3.inc b/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3.inc
deleted file mode 100644
index 1c71d7bb..00000000
--- a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3.inc
+++ /dev/null
@@ -1,20 +0,0 @@
1SRC_URI += "file://nodolt.patch \
2 file://crosscompile.patch"
3
4# Misc build failure for master HEAD
5SRC_URI += "file://fix_open_max_preprocessor_error.patch"
6
7# What once were warnings now are errors, fix those up
8SRC_URI += "file://werror-address-fix.patch \
9 file://ptr-to-int-cast-fix.patch"
10
11PROTO_DEPS += "xf86driproto dri2proto"
12DEPENDS += "font-util"
13EXTRA_OECONF += "--enable-dri --enable-dri2 --enable-dga"
14
15LIC_FILES_CHKSUM = "file://COPYING;md5=3dd2bbe3563837f80ed8926b06c1c353"
16
17SRC_URI[md5sum] = "5bef6839a76d029204ab31aa2fcb5201"
18SRC_URI[sha256sum] = "864831f51e841ff37f2445d1c85b86b559c8860a435fb496aead4f256a2b141d"
19
20PR = "r2"
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/crosscompile.patch b/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/crosscompile.patch
deleted file mode 100644
index 2f98bb8c..00000000
--- a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/crosscompile.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1Upstream-Status: Inappropriate [configuration]
2
3diff --git a/configure.ac b/configure.ac
4index b3b752c..600500b 100644
5--- a/configure.ac
6+++ b/configure.ac
7@@ -523,13 +523,9 @@ dnl Uses --default-font-path if set, otherwise checks for /etc/X11/fontpath.d,
8 dnl otherwise uses standard subdirectories of FONTROOTDIR. When cross
9 dnl compiling, assume default font path uses standard FONTROOTDIR directories.
10 DEFAULT_FONT_PATH="${FONTMISCDIR}/,${FONTTTFDIR}/,${FONTOTFDIR}/,${FONTTYPE1DIR}/,${FONT100DPIDIR}/,${FONT75DPIDIR}/"
11-if test "$cross_compiling" != yes; then
12- AC_CHECK_FILE([${sysconfdir}/X11/fontpath.d],
13- [DEFAULT_FONT_PATH='catalogue:${sysconfdir}/X11/fontpath.d'],
14- [case $host_os in
15+ case $host_os in
16 darwin*) DEFAULT_FONT_PATH="${DEFAULT_FONT_PATH},/Library/Fonts,/System/Library/Fonts" ;;
17- esac])
18-fi
19+ esac
20 AC_ARG_WITH(default-font-path, AS_HELP_STRING([--with-default-font-path=PATH], [Comma separated list of font dirs]),
21 [ FONTPATH="$withval" ],
22 [ FONTPATH="${DEFAULT_FONT_PATH}" ])
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/fix_open_max_preprocessor_error.patch b/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/fix_open_max_preprocessor_error.patch
deleted file mode 100644
index 9c33072c..00000000
--- a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/fix_open_max_preprocessor_error.patch
+++ /dev/null
@@ -1,15 +0,0 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3Index: git/os/osdep.h
4===================================================================
5--- git.orig/os/osdep.h 2008-10-07 18:38:21.000000000 +0100
6+++ git/os/osdep.h 2008-10-07 18:39:36.000000000 +0100
7@@ -92,7 +92,7 @@
8 * like sysconf(_SC_OPEN_MAX) is not supported.
9 */
10
11-#if OPEN_MAX <= 256
12+#if 0
13 #define MAXSOCKS (OPEN_MAX - 1)
14 #else
15 #define MAXSOCKS 256
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/macro_tweak.patch b/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/macro_tweak.patch
deleted file mode 100644
index 2b754271..00000000
--- a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/macro_tweak.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1This is the revised version of files/macro_tweak.patch for
2xorg-server 1.8.99.904.
3
4the files/macro_tweak.patch can not removed now since it is used by
5xserver-kdrive-1.7.99.2 and xserver-xf86-lite_1.7.99.2. Once they
6are all upgraded to 1.8.99.904, the the files/macro_tweak.patch
7can be safely replace by this patch.
8
9Upstream-Status: Pending
10
11Signed-off-by: Yu Ke <ke.yu@intel.com>
12
13diff --git a/xorg-server.m4 b/xorg-server.m4
14index bdecf62..040fdb8 100644
15--- a/xorg-server.m4
16+++ b/xorg-server.m4
17@@ -28,10 +28,12 @@ dnl
18 # Checks for the $1 define in xorg-server.h (from the sdk). If it
19 # is defined, then add $1 to $REQUIRED_MODULES.
20
21+m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR)
22+
23 AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
24 AC_REQUIRE([PKG_PROG_PKG_CONFIG])
25 SAVE_CFLAGS="$CFLAGS"
26- CFLAGS="$CFLAGS -I`$PKG_CONFIG --variable=sdkdir xorg-server`"
27+ CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=sdkdir xorg-server`"
28 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
29 #include "xorg-server.h"
30 #if !defined $1
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/nodolt.patch b/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/nodolt.patch
deleted file mode 100644
index 9cd7f932..00000000
--- a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/nodolt.patch
+++ /dev/null
@@ -1,14 +0,0 @@
1Upstream-Status: Inappropriate [configuration]
2
3Index: git/configure.ac
4===================================================================
5--- git.orig/configure.ac 2009-01-15 20:35:31.000000000 +0000
6+++ git/configure.ac 2009-01-15 20:35:38.000000000 +0000
7@@ -62,7 +62,6 @@
8 AC_LIBTOOL_WIN32_DLL
9 AC_DISABLE_STATIC
10 AC_PROG_LIBTOOL
11-DOLT
12 AC_PROG_MAKE_SET
13 PKG_PROG_PKG_CONFIG
14 AC_PROG_LEX
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/ptr-to-int-cast-fix.patch b/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/ptr-to-int-cast-fix.patch
deleted file mode 100644
index 705cffcb..00000000
--- a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/ptr-to-int-cast-fix.patch
+++ /dev/null
@@ -1,92 +0,0 @@
1Upstream-Status: Inappropriate [already upstream]
2
3It's broken for devices with BARs above 4G, and the sysfs method should
4work everywhere anyway. As a pleasant side effect, this fixes some
5warnings:
6
7fbdevhw.c: In function 'fbdev_open_pci':
8fbdevhw.c:333:4: warning: cast from pointer to integer of different size
9fbdevhw.c:334:4: warning: cast from pointer to integer of different size
10fbdevhw.c:336:4: warning: cast from pointer to integer of different size
11fbdevhw.c:337:4: warning: cast from pointer to integer of different size
12
13Signed-off-by: Adam Jackson <ajax (a] redhat.com>
14Integrated-by: Tom Zanussi <tom.zanussi (a] intel.com>
15
16Index: xorg-server-1.9.3/hw/xfree86/fbdevhw/fbdevhw.c
17===================================================================
18--- xorg-server-1.9.3.orig/hw/xfree86/fbdevhw/fbdevhw.c 2012-01-12 10:32:07.097729262 -0600
19+++ xorg-server-1.9.3/hw/xfree86/fbdevhw/fbdevhw.c 2012-01-12 10:32:55.076732780 -0600
20@@ -291,14 +291,7 @@
21 {
22 struct fb_fix_screeninfo fix;
23 char filename[256];
24- int fd,i,j;
25-
26-
27- /* There are two ways to that we can determine which fb device is
28- * associated with this PCI device. The more modern way is to look in
29- * the sysfs directory for the PCI device for a file named
30- * "graphics/fb*"
31- */
32+ int fd, i;
33
34 for (i = 0; i < 8; i++) {
35 sprintf(filename,
36@@ -331,55 +324,10 @@
37 }
38 }
39
40-
41- /* The other way is to examine the resources associated with each fb
42- * device and see if there is a match with the PCI device. This technique
43- * has some problems on certain mixed 64-bit / 32-bit architectures.
44- * There is a flaw in the fb_fix_screeninfo structure in that it only
45- * returns the low 32-bits of the address of the resources associated with
46- * a device. However, on a mixed architecture the base addresses of PCI
47- * devices, even for 32-bit applications, may be higher than 0x0f0000000.
48- */
49-
50- for (i = 0; i < 8; i++) {
51- sprintf(filename,"/dev/fb%d",i);
52- if (-1 == (fd = open(filename,O_RDWR,0))) {
53- xf86DrvMsg(-1, X_WARNING,
54- "open %s: %s\n", filename, strerror(errno));
55- continue;
56- }
57- if (-1 == ioctl(fd,FBIOGET_FSCREENINFO,(void*)&fix)) {
58- close(fd);
59- continue;
60- }
61- for (j = 0; j < 6; j++) {
62- const pciaddr_t res_start = pPci->regions[j].base_addr;
63- const pciaddr_t res_end = res_start + pPci->regions[j].size;
64-
65- if ((0 != fix.smem_len &&
66- (pciaddr_t) fix.smem_start >= res_start &&
67- (pciaddr_t) fix.smem_start < res_end) ||
68- (0 != fix.mmio_len &&
69- (pciaddr_t) fix.mmio_start >= res_start &&
70- (pciaddr_t) fix.mmio_start < res_end))
71- break;
72- }
73- if (j == 6) {
74- close(fd);
75- continue;
76- }
77- if (namep) {
78- *namep = xnfalloc(16);
79- strncpy(*namep,fix.id,16);
80- }
81- return fd;
82- }
83-
84 if (namep)
85 *namep = NULL;
86
87- xf86DrvMsg(-1, X_ERROR,
88- "Unable to find a valid framebuffer device\n");
89+ xf86DrvMsg(-1, X_ERROR, "Unable to find a valid framebuffer device\n");
90 return -1;
91 }
92
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/werror-address-fix.patch b/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/werror-address-fix.patch
deleted file mode 100644
index 49d3f947..00000000
--- a/common/recipes-graphics/xorg-xserver/xserver-xorg-1.9.3/werror-address-fix.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1Upstream-Status: Inappropriate [yocto-specific]
2
3This is fixed upstream by actually making these tests meaningful.
4As they stand, the warning is correct and they're no-ops, so remove
5them.
6
7Signed-off-by: Tom Zanussi <tom.zanussi (a] intel.com>
8
9Index: xorg-server-1.9.3/Xext/xvmc.c
10===================================================================
11--- xorg-server-1.9.3.orig/Xext/xvmc.c 2012-01-12 09:57:36.306947860 -0600
12+++ xorg-server-1.9.3/Xext/xvmc.c 2012-01-12 10:24:59.286729946 -0600
13@@ -467,7 +467,6 @@
14 return Success;
15 }
16
17-
18 static int
19 ProcXvMCListSubpictureTypes(ClientPtr client)
20 {
21@@ -487,9 +486,6 @@
22
23 pScreen = pPort->pAdaptor->pScreen;
24
25- if(XvMCScreenKey == NULL) /* No XvMC adaptors */
26- return BadMatch;
27-
28 if(!(pScreenPriv = XVMC_GET_PRIVATE(pScreen)))
29 return BadMatch; /* None this screen */
30
31@@ -668,9 +664,6 @@
32 {
33 ExtensionEntry *extEntry;
34
35- if(XvMCScreenKey == NULL) /* nobody supports it */
36- return;
37-
38 if(!(XvMCRTContext = CreateNewResourceType(XvMCDestroyContextRes,
39 "XvMCRTContext")))
40 return;
41@@ -746,8 +739,6 @@
42 XvMCAdaptorPtr adaptor = NULL;
43 int i;
44
45- if(XvMCScreenKey == NULL) return NULL;
46-
47 if(!(pScreenPriv = XVMC_GET_PRIVATE(pScreen)))
48 return NULL;
49
diff --git a/common/recipes-graphics/xorg-xserver/xserver-xorg_1.9.3.bb b/common/recipes-graphics/xorg-xserver/xserver-xorg_1.9.3.bb
deleted file mode 100644
index f62cad20..00000000
--- a/common/recipes-graphics/xorg-xserver/xserver-xorg_1.9.3.bb
+++ /dev/null
@@ -1,4 +0,0 @@
1require recipes-graphics/xorg-xserver/xserver-xorg.inc
2require xserver-xorg-${PV}.inc
3
4PE = "1"