summaryrefslogtreecommitdiffstats
path: root/common/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-10-17 11:38:41 +0100
committerTom Zanussi <tom.zanussi@intel.com>2012-11-06 18:09:01 -0600
commitfa655a783bc1e41109f408ff49b785d664f64106 (patch)
tree143887ecb67545482042e780db6fec4bbac16c34 /common/recipes-graphics
parent606f2a87999c5fe5131879ca343c74c3df298892 (diff)
downloadmeta-intel-fa655a783bc1e41109f408ff49b785d664f64106.tar.gz
emgd-driver-bin: add xorg-abi-video- dependency
xserver changes the driver ABI at will, and refuses to load drivers with the wrong ABI version. So that we know about this error at image build time instead of when xserver fails to start, RDEPEND on the ABI version we expect. This dependency is added programmatically so that bitbake doesn't look for a provider of xorg-abi-video-8 at parse time, which it won't find. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-graphics')
-rw-r--r--common/recipes-graphics/xorg-driver/emgd-driver-bin_1.14.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.14.bb b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.14.bb
index e068f7a6..cc78d61f 100644
--- a/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.14.bb
+++ b/common/recipes-graphics/xorg-driver/emgd-driver-bin_1.14.bb
@@ -19,6 +19,15 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/${EMGD_LIC_DIR}/License.txt;md5=b54f01caaf
19DEPENDS = "rpm-native xz-native" 19DEPENDS = "rpm-native xz-native"
20RDEPENDS = "libxcb-dri2" 20RDEPENDS = "libxcb-dri2"
21 21
22# Add the ABI dependency at package generation time, as otherwise bitbake will
23# attempt to find a provider for it (and fail) when it does the parse.
24#
25# This version *must* be kept correct.
26python populate_packages_prepend() {
27 pn = d.getVar("PN", True)
28 d.appendVar("RDEPENDS_" + pn, " xorg-abi-video-8")
29}
30
22SRC_URI = "https://edc.intel.com/Download.aspx?id=6190;downloadfilename=LIN_IEMGD_1_14_GOLD_2443.tgz" 31SRC_URI = "https://edc.intel.com/Download.aspx?id=6190;downloadfilename=LIN_IEMGD_1_14_GOLD_2443.tgz"
23 32
24SRC_URI[md5sum] = "733a7f237ffce21238ce2c9956df4fd6" 33SRC_URI[md5sum] = "733a7f237ffce21238ce2c9956df4fd6"