summaryrefslogtreecommitdiffstats
path: root/common/recipes-graphics/xorg-xserver/emgd-driver-bin_1.14.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-07-16 01:40:42 -0700
committerTom Zanussi <tom.zanussi@intel.com>2012-07-31 23:07:15 -0500
commit83a4aa1a44cb21a44c6a69f08a193a724294442a (patch)
tree60aa47eb708413d9228cb7bbbf7870cb54d08bf5 /common/recipes-graphics/xorg-xserver/emgd-driver-bin_1.14.bb
parent7bd163e41f6b861448ab19a13ded4b7c48e16641 (diff)
downloadmeta-intel-83a4aa1a44cb21a44c6a69f08a193a724294442a.tar.gz
emgd-driver-bin: upgrade from 1.10 to 1.14
1.14 is the latest released driver for emgd. This change is tested on crownbay machine. Add runtime dependency to libxcb-dri2 Otherwise the libxcb-dri2.so is not getting installed, and video acceleration of emgd does not work. It is dynamic dependency of emgd_drv_video.so put files in gstreamer-0.10/.debug directory to the debug package. It avoids debug files packaging warnings. add downloadfilename param to SRC_URI As the url does not have the filename of the tarball, specify it here so that updated wget bitbake fetcher can save the downloaded file accordingly. BTW now EDC has also published another download URL on our request: http://edc.intel.com/App_Shared/Downloads/LIN_IEMGD_1_14_GOLD_2443.tgz And update emgd driver version in the README. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Tested-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-graphics/xorg-xserver/emgd-driver-bin_1.14.bb')
-rw-r--r--common/recipes-graphics/xorg-xserver/emgd-driver-bin_1.14.bb92
1 files changed, 92 insertions, 0 deletions
diff --git a/common/recipes-graphics/xorg-xserver/emgd-driver-bin_1.14.bb b/common/recipes-graphics/xorg-xserver/emgd-driver-bin_1.14.bb
new file mode 100644
index 00000000..b1ba1b84
--- /dev/null
+++ b/common/recipes-graphics/xorg-xserver/emgd-driver-bin_1.14.bb
@@ -0,0 +1,92 @@
1SUMMARY = "EMGD 1.14 xserver binaries"
2DESCRIPTION = "EMGD 1.14 includes some userspace binaries that use non-free \
3licensing, which are now available via a non-click-through downloadable \
4tarball, and is what this recipe now uses. Since it is a non-free license, \
5this recipe is marked as 'License_emgd-driver-bin_1.14' and you need to add \
6to LICENSE_FLAGS_WHITELIST += \"License_emgd-driver-bin_1.14\" to your \
7local.conf in order to enable it in a build."
8LICENSE = "Intel-binary-only"
9LICENSE_FLAGS = "license_${PN}_${PV}"
10PR = "r1"
11
12EMGD_LIC_DIR = "IEMGD_HEAD_Linux/License"
13EMGD_RPM_DIR = "IEMGD_HEAD_Linux/MeeGo1.2"
14EMGD_VIDEO_PLUGIN_DIR = "../common/video_plugin"
15
16LIC_FILES_CHKSUM = "file://${WORKDIR}/${EMGD_LIC_DIR}/License.txt;md5=b54f01caaf8483b3cb60c0c40f2bf22d"
17
18DEPENDS = "rpm-native xz-native"
19RDEPENDS = "libxcb-dri2"
20
21SRC_URI = "https://edc.intel.com/Download.aspx?id=6190;downloadfilename=LIN_IEMGD_1_14_GOLD_2443.tgz"
22
23SRC_URI[md5sum] = "733a7f237ffce21238ce2c9956df4fd6"
24SRC_URI[sha256sum] = "bcdc333b5edbda7c746a83ef821ded4a0ca55ead30980e4e3680cdb6469f45a2"
25
26# These are closed binaries generated elsewhere so don't check ldflags
27INSANE_SKIP_${PN} = "ldflags"
28
29FILES_${PN} += "${libdir}/dri ${libdir}/gstreamer-0.10 ${libdir}/xorg/modules/drivers"
30FILES_${PN}-dbg += "${libdir}/xorg/modules/drivers/.debug ${libdir}/dri/.debug ${libdir}/gstreamer-0.10/.debug"
31
32S = "${WORKDIR}/${EMGD_RPM_DIR}"
33
34do_install () {
35 # A gstreamer VA buffer library
36 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/gst-vabuffer*.rpm | cpio -id
37
38 # MIX Common contains common classes, datatype, header files used by other MIX components
39 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/mixcommon*.rpm | cpio -id
40
41 # MIX Video Bitstream Parser is an user library interface for various video format bitstream parsing
42 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/mixvbp*.rpm | cpio -id
43
44 # MIX Video is an user library interface for various video codecs available on the platform.
45 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/mixvideo*.rpm | cpio -id
46
47 install -d -m 0755 ${D}${libdir}/gstreamer-0.10
48 install -m 0755 ${S}/usr/lib/* ${D}${libdir}/
49
50 # A gstreamer plugin that uses MIX Video for hardware accelerated video decoding and rendering.
51 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/gst-plugins-mixvideo*.rpm | cpio -id
52
53 # A collection of gstreamer plugins that uses VA libraries for hardware accelerated video rendering and text overlay.
54 rpm2cpio ${S}/${EMGD_VIDEO_PLUGIN_DIR}/gst-plugins-va*.rpm | cpio -id
55
56 install -m 0755 ${S}/usr/lib/gstreamer-0.10/* ${D}${libdir}/gstreamer-0.10/
57
58 # EMGD runtime graphics libraries
59 rpm2cpio ${S}/emgd-bin*.rpm | xz -d | cpio -id
60
61 install -d -m 0755 ${D}${libdir}/dri
62 install -d -m 0755 ${D}${libdir}/xorg/modules/drivers
63 install -d -m 0755 ${D}${sysconfdir}
64 install -d -m 0755 ${D}${mandir}/man4
65 install -m 0755 ${S}/usr/lib/*.so.* ${D}${libdir}/
66 install -m 0755 ${S}/usr/lib/dri/* ${D}${libdir}/dri/
67 install -m 0755 ${S}/usr/lib/xorg/modules/drivers/* ${D}${libdir}/xorg/modules/drivers/
68 install -m 0755 ${S}/etc/* ${D}${sysconfdir}/
69 install -m 0755 ${S}/usr/share/man/man4/* ${D}${mandir}/man4/
70
71 # Khronos development headers needed for EGL, OpenGL-ES, and OpenVG development
72 rpm2cpio ${S}/emgd-devel*.rpm | xz -d | cpio -id
73
74 install -d -m 0755 ${D}${includedir}/EGL
75 install -m 0755 ${S}/usr/include/EGL/*.h ${D}${includedir}/EGL/
76 install -d -m 0755 ${D}${includedir}/GLES
77 install -m 0755 ${S}/usr/include/GLES/*.h ${D}${includedir}/GLES/
78 install -d -m 0755 ${D}${includedir}/GLES2
79 install -m 0755 ${S}/usr/include/GLES2/*.h ${D}${includedir}/GLES2/
80 install -d -m 0755 ${D}${includedir}/KHR
81 install -m 0755 ${S}/usr/include/KHR/*.h ${D}${includedir}/KHR/
82 install -d -m 0755 ${D}${includedir}/VG
83 install -m 0755 ${S}/usr/include/VG/*.h ${D}${includedir}/VG/
84
85 ln -sf libEGL.so.1 ${D}${libdir}/libEGL.so
86 ln -sf libGLES_CM.so.1 ${D}${libdir}/libGLES_CM.so
87 ln -sf libGLESv2.so.2 ${D}${libdir}/libGLESv2.so
88 ln -sf libOpenVG.so.1 ${D}${libdir}/libOpenVG.so
89 ln -sf libOpenVGU.so.1 ${D}${libdir}/libOpenVGU.so
90}
91
92LEAD_SONAME = "libEGL.so"