summaryrefslogtreecommitdiffstats
path: root/common/recipes-graphics/xorg-driver/xorg-driver-common.inc
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-10-09 10:49:41 -0700
committerTom Zanussi <tom.zanussi@intel.com>2012-10-12 08:40:32 -0500
commit7397bb5b448f8e38c310f207bdfcff4b64dfa000 (patch)
treeed563120f0b0d99e6a24584bf627c976d521181f /common/recipes-graphics/xorg-driver/xorg-driver-common.inc
parent5d8a05811101f7d69994f4028ec620c4480f6da4 (diff)
downloadmeta-intel-7397bb5b448f8e38c310f207bdfcff4b64dfa000.tar.gz
xf86-video-intel: Bring 2.20.0 version to match released graphics stack
The Intel Linux graphics stack version 12.07 released on 2012-07-24 requires version 2.20.0 as seen here: http://intellinuxgraphics.org/2012.07.html Currently oecore has 2.19.0 version. So get this 2.20.0 version in meta-intel layer to be used by sugarbay and other BSPs using the Intel graphics stack. Also took changes from version 2.20.8 recipe from Ross Burton's branch. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-graphics/xorg-driver/xorg-driver-common.inc')
-rw-r--r--common/recipes-graphics/xorg-driver/xorg-driver-common.inc33
1 files changed, 33 insertions, 0 deletions
diff --git a/common/recipes-graphics/xorg-driver/xorg-driver-common.inc b/common/recipes-graphics/xorg-driver/xorg-driver-common.inc
new file mode 100644
index 00000000..1ed2742d
--- /dev/null
+++ b/common/recipes-graphics/xorg-driver/xorg-driver-common.inc
@@ -0,0 +1,33 @@
1DESCRIPTION = "X driver"
2HOMEPAGE = "http://www.x.org"
3BUGTRACKER = "https://bugs.freedesktop.org"
4SECTION = "x11/drivers"
5LICENSE = "MIT-X"
6
7PE = "2"
8INC_PR = "r0"
9
10DEPENDS = "virtual/xserver xproto randrproto util-macros"
11
12SRC_URI = "${XORG_MIRROR}/individual/driver/${BPN}-${PV}.tar.bz2"
13
14S = "${WORKDIR}/${BPN}-${PV}"
15
16FILES_${PN} += " ${libdir}/xorg/modules/drivers/*.so"
17FILES_${PN}-dbg += " ${libdir}/xorg/modules/drivers/.debug"
18
19inherit autotools pkgconfig
20
21# AC_CHECK_FILE doesn't work when cross compiling, so we create a replacement
22# macro that simply assumes the test succeeds.
23do_configure_prepend () {
24 echo 'AC_DEFUN(CC_AC_CHECK_FILE, $2)' > configure.ac.new
25 sed 's/AC_CHECK_FILE/CC_AC_CHECK_FILE/g' configure.ac >> configure.ac.new
26 mv configure.ac.new configure.ac
27}
28
29# FIXME: We don't want to include the libtool archives (*.la) from modules
30# directory, as they serve no useful purpose. Upstream should fix Makefile.am
31do_install_append() {
32 find ${D}${libdir}/xorg/modules -regex ".*\.la$" | xargs rm -f --
33}