summaryrefslogtreecommitdiffstats
path: root/common/recipes-graphics/mesa/mesa-dri_9.0.2.bbappend
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2013-02-12 10:17:23 -0800
committerDarren Hart <dvhart@linux.intel.com>2013-02-12 10:17:23 -0800
commita75b393fd7cf6c480a92e612e1e3acc2bbf9df34 (patch)
tree18c6faed3f6bd64ece25e91b0cbd71a3cd96eb21 /common/recipes-graphics/mesa/mesa-dri_9.0.2.bbappend
parent575f93dd4ba1fb9aca8a58dc66e9066eca0a3925 (diff)
downloadmeta-intel-a75b393fd7cf6c480a92e612e1e3acc2bbf9df34.tar.gz
mesa-dri: Update bbappend to version 9.0.2
Adjust bbappend to match changes in OE-Core. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'common/recipes-graphics/mesa/mesa-dri_9.0.2.bbappend')
-rw-r--r--common/recipes-graphics/mesa/mesa-dri_9.0.2.bbappend24
1 files changed, 24 insertions, 0 deletions
diff --git a/common/recipes-graphics/mesa/mesa-dri_9.0.2.bbappend b/common/recipes-graphics/mesa/mesa-dri_9.0.2.bbappend
new file mode 100644
index 00000000..b92831d3
--- /dev/null
+++ b/common/recipes-graphics/mesa/mesa-dri_9.0.2.bbappend
@@ -0,0 +1,24 @@
1
2# The emgd binary driver also provides egl, gles1, gles2 library & headers.
3# To avoid conflict disable egl, gles1, gles2 from meta-dri if the BSP image
4# is bundling the emgd driver.
5
6python __anonymous () {
7 import re
8 xserver = d.getVar('XSERVER', True)
9 if xserver and 'emgd-driver-bin' in xserver.split(' '):
10 extra_oeconf = d.getVar('EXTRA_OECONF', True).split()
11 take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"]
12 put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"]
13 pattern = re.compile("--with-egl-platforms")
14 new_extra_oeconf = [ ]
15 for i in extra_oeconf:
16 if ( i not in take_out ) and ( not pattern.match(i)):
17 new_extra_oeconf.append(i)
18 for i in put_in:
19 new_extra_oeconf.append(i)
20
21 d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf))
22 depends = d.getVar('DEPENDS', True)
23 d.setVar('DEPENDS', depends + " emgd-driver-bin")
24}