summaryrefslogtreecommitdiffstats
path: root/common/recipes-graphics/mesa/mesa-dri_9.0.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-11 10:22:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-11 10:23:32 +0000
commitcd1ad0989e12330a3c3f5864d7da8ab81b789f7d (patch)
treee7fc4c3d9a39b9d1c22cf8717e7271ce3acc7641 /common/recipes-graphics/mesa/mesa-dri_9.0.1.bb
parent227d8fa72c2ffbccee4c21ffb32841129a550729 (diff)
downloadmeta-intel-cd1ad0989e12330a3c3f5864d7da8ab81b789f7d.tar.gz
mesa-dri: Update bbappend to version 9.0.1
Adjust bbappend to match changes in OE-Core. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'common/recipes-graphics/mesa/mesa-dri_9.0.1.bb')
-rw-r--r--common/recipes-graphics/mesa/mesa-dri_9.0.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/common/recipes-graphics/mesa/mesa-dri_9.0.1.bb b/common/recipes-graphics/mesa/mesa-dri_9.0.1.bb
new file mode 100644
index 00000000..b92831d3
--- /dev/null
+++ b/common/recipes-graphics/mesa/mesa-dri_9.0.1.bb
@@ -0,0 +1,24 @@
1
2# The emgd binary driver also provides egl, gles1, gles2 library & headers.
3# To avoid conflict disable egl, gles1, gles2 from meta-dri if the BSP image
4# is bundling the emgd driver.
5
6python __anonymous () {
7 import re
8 xserver = d.getVar('XSERVER', True)
9 if xserver and 'emgd-driver-bin' in xserver.split(' '):
10 extra_oeconf = d.getVar('EXTRA_OECONF', True).split()
11 take_out = ["--enable-egl", "--enable-gles1", "--enable-gles2"]
12 put_in = ["--disable-egl", "--disable-gles1", "--disable-gles2"]
13 pattern = re.compile("--with-egl-platforms")
14 new_extra_oeconf = [ ]
15 for i in extra_oeconf:
16 if ( i not in take_out ) and ( not pattern.match(i)):
17 new_extra_oeconf.append(i)
18 for i in put_in:
19 new_extra_oeconf.append(i)
20
21 d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf))
22 depends = d.getVar('DEPENDS', True)
23 d.setVar('DEPENDS', depends + " emgd-driver-bin")
24}