summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended/dpdk/dpdk_1.7.0.bb
diff options
context:
space:
mode:
authorSreeju Selvaraj <sreeju.armughanx.selvaraj@intel.com>2014-09-29 18:39:33 +0800
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-10-02 10:24:51 -0500
commitd9eaf5edeb848671db0a7ac864850833af82bef2 (patch)
tree66e4c5708a492b1de7e273f85d71c86b4836d6fe /common/recipes-extended/dpdk/dpdk_1.7.0.bb
parent99c854538af91c7aae854f0b8460acacd2584450 (diff)
downloadmeta-intel-d9eaf5edeb848671db0a7ac864850833af82bef2.tar.gz
meta-intel/common: Upgrade DPDK to v1.7.0
Added support for DPDK v1.7.0. Added PACKAGECONFIG mechanism to explicitly disable the use of fuse and qat which are dependencies for example apps dpdk_qat and vhost. Added config variables CONFIG_EXAMPLE_DPDK_QAT and CONFIG_EXAMPLE_DPDK_VHOST to enable or disable the compilation of example apps dpdk_qat and vhost. Resolved the installation failure found in example app ip_pipeline by cherry-picking the patch from dpdk.org. Resolved the test failure found in example app ring_pmd_autotest by cherry-picking the patches from dpdk.org. Signed-off-by: Sreeju Selvaraj <sreeju.armughanx.selvaraj@intel.com> Acked-by: Ong Boon Leong <boon.leong.ong@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-extended/dpdk/dpdk_1.7.0.bb')
-rw-r--r--common/recipes-extended/dpdk/dpdk_1.7.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/common/recipes-extended/dpdk/dpdk_1.7.0.bb b/common/recipes-extended/dpdk/dpdk_1.7.0.bb
new file mode 100644
index 00000000..581f1d4a
--- /dev/null
+++ b/common/recipes-extended/dpdk/dpdk_1.7.0.bb
@@ -0,0 +1,41 @@
1include dpdk.inc
2
3SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
4 file://dpdk-1.7.0-examples-Add-config-variables-to-enable-disable-dpdk.patch \
5 file://dpdk-1.7.0-examples-pipeline-build-with-all-examples.patch \
6 file://dpdk-1.7.0-ring-remove-extra-devices-creation-with-vdev-option.patch \
7 file://dpdk-1.7.0-ring-simplify-unit-tests.patch \
8 "
9
10SRC_URI[dpdk.md5sum] = "07907d7b1a64888a459a971c45818038"
11SRC_URI[dpdk.sha256sum] = "aafc290260b5002d248ab8f8c8ffa76454d4b1382aa3c82ae2700ecce481397a"
12
13export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
14
15# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
16# fuse is in meta-filesystems and qat is not yet upstreamed.
17# So adding mechanism to explicitly disable the use of fuse and qat.
18# To enable, uncomment the below line or include in .bbappend.
19# PACKAGECONFIG ?= " dpdk_qat vhost "
20
21PACKAGECONFIG[dpdk_qat] = ",,qat"
22PACKAGECONFIG[vhost] = ",,fuse"
23
24do_compile_append () {
25
26 cd ${S}/examples/
27
28 # Disable the compilation of example apps dpdk_qat and vhost if they are
29 # not included in the PACKAGECONFIG
30 export CONFIG_EXAMPLE_DPDK_QAT=${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}
31 export CONFIG_EXAMPLE_DPDK_VHOST="${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"
32
33 ###############################################################
34 # In order to make use of dpdk.inc for example app installation
35 # without failure, override the default build directory
36 ###############################################################
37 oe_runmake CROSS="${TARGET_PREFIX}" O="${S}/examples/$@/"
38}
39
40
41