summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended/dpdk/dpdk
diff options
context:
space:
mode:
authorSyed Mohamad Fauzi, Syed Johan Arif <syed.johan.arif.syed.mohamad.fauzi@intel.com>2017-07-28 16:42:51 +0800
committerSaul Wold <sgw@linux.intel.com>2017-07-31 09:00:58 -0700
commitda5f7e708166ad2ecc5dabc88e78f414ca75970a (patch)
treec0a2c48bf29d2135af86e8f141c5f1922034715f /common/recipes-extended/dpdk/dpdk
parentd0ba6fc045dffda5aa1e6e015b926615febfbf9f (diff)
downloadmeta-intel-da5f7e708166ad2ecc5dabc88e78f414ca75970a.tar.gz
dpdk: upgrade to version 17.05
Signed-off-by: Syed Mohamad Fauzi, Syed Johan Arif <syed.johan.arif.syed.mohamad.fauzi@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-extended/dpdk/dpdk')
-rw-r--r--common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-config-variable-to-enable-disable-dpdk_qat.patch31
-rw-r--r--common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch43
-rw-r--r--common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch6
3 files changed, 3 insertions, 77 deletions
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-config-variable-to-enable-disable-dpdk_qat.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-config-variable-to-enable-disable-dpdk_qat.patch
deleted file mode 100644
index cd517052..00000000
--- a/common/recipes-extended/dpdk/dpdk/dpdk-16.04-add-config-variable-to-enable-disable-dpdk_qat.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From a424a79b1422f1877de3ee7aee6f781aeacc3630 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Tue, 18 Aug 2015 12:36:02 +0800
4Subject: [PATCH] examples: add config variable to enable/disable dpdk_qat
5
6Upstream-Status: Inappropriate [configuration]
7
8Add CONFIG_EXAMPLE_DPDK_QAT to control compilation of dpdk_qat
9example by PACKAGECONFIG
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 examples/Makefile | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/examples/Makefile b/examples/Makefile
17index b4eddbd..1bc14b0 100644
18--- a/examples/Makefile
19+++ b/examples/Makefile
20@@ -41,7 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
21 DIRS-y += cmdline
22 DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
23 ifneq ($(ICP_ROOT),)
24-DIRS-y += dpdk_qat
25+DIRS-$(CONFIG_EXAMPLE_DPDK_QAT) += dpdk_qat
26 endif
27 DIRS-y += exception_path
28 DIRS-y += helloworld
29--
301.7.9.5
31
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch
deleted file mode 100644
index 75bb517d..00000000
--- a/common/recipes-extended/dpdk/dpdk/dpdk-16.04-point-to-the-right-include-and-lib-path.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 928595c80ae28d19861d7e76ed898a8fb3f2c1dc Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Fri, 24 Jul 2015 23:57:17 +0800
4Subject: [PATCH] dpdk: point to the right include and lib path
5
6Upstream-Status: Inappropriate [Configuration]
7
8Make sure that we point to the right location of qat
9lac headers and library.
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 examples/dpdk_qat/Makefile | 7 ++-----
14 1 file changed, 2 insertions(+), 5 deletions(-)
15
16diff --git a/examples/dpdk_qat/Makefile b/examples/dpdk_qat/Makefile
17index f1e06a1..5b906f7 100644
18--- a/examples/dpdk_qat/Makefile
19+++ b/examples/dpdk_qat/Makefile
20@@ -66,18 +66,15 @@ SRCS-y := main.c crypto.c
21
22 CFLAGS += -O3
23 CFLAGS += $(WERROR_FLAGS)
24-CFLAGS += -I$(ICP_ROOT)/quickassist/include \
25- -I$(ICP_ROOT)/quickassist/include/lac \
26- -I$(ICP_ROOT)/quickassist/lookaside/access_layer/include
27+CFLAGS += -I$(ICP_LAC_API_DIR)
28
29 # From CRF 1.2 driver, library was renamed to libicp_qa_al.a
30 ifneq ($(wildcard $(ICP_ROOT)/build/icp_qa_al.a),)
31 ICP_LIBRARY_PATH = $(ICP_ROOT)/build/icp_qa_al.a
32 else
33-ICP_LIBRARY_PATH = $(ICP_ROOT)/build/libicp_qa_al.a
34+ICP_LIBRARY_PATH = $(ICP_LIB_ROOT)/libicp_qa_al.a
35 endif
36
37-LDLIBS += -L$(ICP_ROOT)/build
38 LDLIBS += $(ICP_LIBRARY_PATH) \
39 -lz \
40 -losal \
41--
421.7.9.5
43
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
index e17d80d1..fc965fa4 100644
--- a/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
+++ b/common/recipes-extended/dpdk/dpdk/dpdk-16.07-dpdk-fix-for-parellel-make-issue.patch
@@ -18,9 +18,9 @@ index 18b41b9..c7c2beb 100644
18--- a/examples/Makefile 18--- a/examples/Makefile
19+++ b/examples/Makefile 19+++ b/examples/Makefile
20@@ -43,6 +43,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor 20@@ -43,6 +43,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
21 ifneq ($(ICP_ROOT),) 21 DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
22 DIRS-y += dpdk_qat 22 DIRS-y += cmdline
23 endif 23 DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
24+DEPDIRS-y += examples/ethtool/lib 24+DEPDIRS-y += examples/ethtool/lib
25 DIRS-y += ethtool 25 DIRS-y += ethtool
26 DIRS-y += exception_path 26 DIRS-y += exception_path