summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
diff options
context:
space:
mode:
authorRahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>2016-10-18 23:22:30 +0800
committerSaul Wold <sgw@linux.intel.com>2016-10-18 12:02:17 -0700
commit485f82ab71604173b698b55a8f4495b3741ce538 (patch)
treede1754c490e503d6c8cb09d7c546c91ac22ba7f4 /common/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
parent6adafe510efbc9721f163adccbc7245e7751b730 (diff)
downloadmeta-intel-485f82ab71604173b698b55a8f4495b3741ce538.tar.gz
dpdk: move dpdk from meta-isg to common
Since there is plan to merge meta-isg layer to common meta-intel layer. So relocate dpdk v16.07 recipe from meta-isg layer to common meta-intel layer. Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch')
-rw-r--r--common/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch b/common/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
new file mode 100644
index 00000000..a4c47112
--- /dev/null
+++ b/common/recipes-extended/dpdk/dpdk/dpdk-16.07-add-sysroot-option-within-app-makefile.patch
@@ -0,0 +1,32 @@
1From a33a9e7559b59bc5fb0988af85062436ec4389a4 Mon Sep 17 00:00:00 2001
2From: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
3Date: Fri, 19 Aug 2016 11:57:49 +0800
4Subject: [PATCH] dpdk: add --sysroot option within app makefile
5
6Upstream-Status: Inappropriate [configuration]
7
8rte.app.mk has been changed to add -Wl, to all items listed
9under EXTRA_LDFLAGS. It causes --sysroot=<path> to not setup
10correctly when we depends on gcc to setup for GNU ld.
11
12Signed-off-by: Rahul Kumar Gupta <rahul.kumarxx.gupta@intel.com>
13---
14 mk/rte.app.mk | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/mk/rte.app.mk b/mk/rte.app.mk
18index eb28e11..296c8c7 100644
19--- a/mk/rte.app.mk
20+++ b/mk/rte.app.mk
21@@ -195,7 +195,7 @@ exe2cmd = $(strip $(call dotfile,$(patsubst %,%.cmd,$(1))))
22 ifeq ($(LINK_USING_CC),1)
23 O_TO_EXE = $(CC) -o $@ $(CFLAGS) $(OBJS-y) $(call linkerprefix, \
24 $(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \
25- $(MAPFLAGS))
26+ $(MAPFLAGS)) $(SYSROOTPATH)
27 else
28 O_TO_EXE = $(LD) -o $@ $(OBJS-y) \
29 $(LDLIBS) $(LDFLAGS) $(LDFLAGS_$(@)) $(EXTRA_LDFLAGS) \
30--
311.9.1
32