summaryrefslogtreecommitdiffstats
path: root/common/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch
diff options
context:
space:
mode:
authorChan Wei Sern <wei.sern.chan@intel.com>2014-07-03 16:43:54 +0800
committerTom Zanussi <tom.zanussi@intel.com>2014-07-17 15:18:30 -0500
commitc249763d3cb92bd06742b7986f08cf844ddb1d51 (patch)
treecd58960f992fce86c081bb057fee5d63f656eb3e /common/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch
parentfef1cbc31ce64d29dedd880274ae6c8a90e0b162 (diff)
downloadmeta-intel-c249763d3cb92bd06742b7986f08cf844ddb1d51.tar.gz
meta-intel/common: Initial Intel DPDK recipe under recipes-extended
This is an initial version of Intel Data Plane Development Kits (DPDK) recipe support. This recipe is targetting on Intel DPDK v1.6.0r2. This recipe is created under meta-intel/common because Intel DPDK can be commonly used several Intel BSP platforms such as Romley, Crystal-Forest & Mohon-peak. We resolved examples apps build failure found in v1.6.0-r2 by cherry-picking patches from v1.7.0 as they are not planned to be fixed in v1.6.0-r2. The example app build failure are found in qos_sched, eal_flags_autotest and cmdline_autotest. Signed-off-by: Chan Wei Sern <wei.sern.chan@intel.com> Acked-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch')
-rw-r--r--common/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/common/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch b/common/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch
new file mode 100644
index 00000000..47b5ece7
--- /dev/null
+++ b/common/recipes-extended/dpdk/dpdk/dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch
@@ -0,0 +1,35 @@
1From ea9a59b26c3c86b498337e968ee8f68c4e263614 Mon Sep 17 00:00:00 2001
2From: Olivier Matz <olivier.matz@6wind.com>
3Date: Fri, 16 May 2014 10:18:59 +0200
4Subject: [PATCH] examples/qos_sched: fix makefile
5
6Upstream-Status: backport
7Imported patch from: http://dpdk.org/browse/dpdk/log/
8
9The example does not compile as the linker complains about duplicated
10symbols.
11
12Remove -lsched from LDLIBS, it is already present in rte.app.mk and
13added by the DPDK framework automatically.
14
15Signed-off-by: Olivier Matz <olivier.matz@6wind.com>
16Acked-by: Thomas Monjalon <thomas.monjalon@6wind.com>
17Signed-off-by: Chan Wei Sern <wei.sern.chan@intel.com>
18---
19 examples/qos_sched/Makefile | 2 --
20 1 file changed, 2 deletions(-)
21
22diff --git a/examples/qos_sched/Makefile b/examples/qos_sched/Makefile
23index b91fe37..9366efe 100755
24--- a/examples/qos_sched/Makefile
25+++ b/examples/qos_sched/Makefile
26@@ -54,6 +54,4 @@ CFLAGS += $(WERROR_FLAGS)
27 CFLAGS_args.o := -D_GNU_SOURCE
28 CFLAGS_cfg_file.o := -D_GNU_SOURCE
29
30-LDLIBS += -lrte_sched
31-
32 include $(RTE_SDK)/mk/rte.extapp.mk
33--
341.9.1
35