summaryrefslogtreecommitdiffstats
path: root/common/recipes-core
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2014-06-17 18:03:49 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-09-04 08:44:50 -0500
commit495db912acea71b5a16e136460f5dd3793573bba (patch)
treeb8a034574c8cf08593c8576832f0124c942c3301 /common/recipes-core
parenta32802715354303eb06503039518555f7aa21535 (diff)
downloadmeta-intel-495db912acea71b5a16e136460f5dd3793573bba.tar.gz
iucode-tool: a new recipe for loading Intel CPU microcode
iucode_tool is a program to manipulate Intel i686 and X86-64 processor microcode update collections, and to use the kernel facilities to update the microcode on Intel system processors. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> Reviewed-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-core')
-rw-r--r--common/recipes-core/microcode/iucode-tool_1.0.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/common/recipes-core/microcode/iucode-tool_1.0.2.bb b/common/recipes-core/microcode/iucode-tool_1.0.2.bb
new file mode 100644
index 00000000..dc63211a
--- /dev/null
+++ b/common/recipes-core/microcode/iucode-tool_1.0.2.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Update Intel CPU microcode"
2
3DESCRIPTION = "iucode_tool is a program to manipulate IntelĀ® i686 and X86-64\
4 processor microcode update collections, and to use the kernel facilities to\
5 update the microcode on Intel system processors. It can load microcode data\
6 files in text and binary format, sort, list and filter the microcode updates\
7 contained in these files, write selected microcode updates to a new file in\
8 binary format, or upload them to the kernel. \
9 It operates on microcode data downloaded directly from Intel:\
10 http://feeds.downloadcenter.intel.com/rss/?p=2371\
11"
12HOMEPAGE = "http://gitorious.org/iucode-tool/"
13BUGTRACKER = "https://bugs.debian.org/cgi-bin/pkgreport.cgi?ordering=normal;archive=0;src=iucode-tool;repeatmerged=0"
14
15LICENSE = "GPLv2+"
16LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
17 file://iucode_tool.c;beginline=1;endline=15;md5=94d9128c5b95d5c249197a3854f40003"
18
19SRC_URI = "git://gitorious.org/iucode-tool/iucode-tool.git"
20SRCREV = "0ba2ebe57681435fdd0d8af2675c84783b5fa2aa"
21S = "${WORKDIR}/git"
22
23inherit autotools
24
25BBCLASSEXTEND = "native"