diff options
author | Nitin A Kamble <nitin.a.kamble@intel.com> | 2014-06-17 18:03:51 -0700 |
---|---|---|
committer | Tom Zanussi <tom.zanussi@linux.intel.com> | 2014-09-04 08:46:30 -0500 |
commit | 7a6c460519c7d5424b512ef1929b3b0694a282ef (patch) | |
tree | 668f65bc2be6770e5f33192f9cab6fe382a08a61 /common/recipes-core | |
parent | 495db912acea71b5a16e136460f5dd3793573bba (diff) | |
download | meta-intel-7a6c460519c7d5424b512ef1929b3b0694a282ef.tar.gz |
intel-microcode: a recipe for Intel microcode datafile
This recipe provides the microcode datafile for Intel Processors.
The recipe provides:
1. microcode.dat file for microcode updating from user space with the
iucode-tool utility.
2. the microcode cpio file which gets bundled with the initrd to support
microcode loading at early boot time.
[ YOCTO #5114 ]
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Acked-by: Darren Hart <dvhart@linux.intel.com>
Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-core')
-rw-r--r-- | common/recipes-core/microcode/intel-microcode_20140624.bb | 52 |
1 files changed, 52 insertions, 0 deletions
diff --git a/common/recipes-core/microcode/intel-microcode_20140624.bb b/common/recipes-core/microcode/intel-microcode_20140624.bb new file mode 100644 index 00000000..b01d8a52 --- /dev/null +++ b/common/recipes-core/microcode/intel-microcode_20140624.bb | |||
@@ -0,0 +1,52 @@ | |||
1 | SUMMARY = "Intel Processor Microcode Datafile for Linux" | ||
2 | HOMEPAGE = "http://www.intel.com/" | ||
3 | DESCRIPTION = "The microcode data file contains the latest microcode\ | ||
4 | definitions for all Intel processors. Intel releases microcode updates\ | ||
5 | to correct processor behavior as documented in the respective processor\ | ||
6 | specification updates. While the regular approach to getting this microcode\ | ||
7 | update is via a BIOS upgrade, Intel realizes that this can be an\ | ||
8 | administrative hassle. The Linux operating system and VMware ESX\ | ||
9 | products have a mechanism to update the microcode after booting.\ | ||
10 | For example, this file will be used by the operating system mechanism\ | ||
11 | if the file is placed in the /etc/firmware directory of the Linux system." | ||
12 | |||
13 | LICENSE = "Intel-Microcode-License" | ||
14 | LIC_FILES_CHKSUM = "file://microcode.dat;md5=3c3b208607a00a3d70aad3af5629f7c7" | ||
15 | |||
16 | SRC_URI = "http://downloadmirror.intel.com/23984/eng/microcode-20140624.tgz" | ||
17 | SRC_URI[md5sum] = "eec20032e6bef99dc4282c0ca317e100" | ||
18 | SRC_URI[sha256sum] = "b4662ac780438a7b2d87e6d26a7066feb807f37c6e5b6fa147089f4edb02ea37" | ||
19 | |||
20 | DEPENDS = "iucode-tool-native" | ||
21 | S = "${WORKDIR}" | ||
22 | |||
23 | inherit allarch | ||
24 | inherit deploy | ||
25 | |||
26 | do_compile() { | ||
27 | mkdir -p ${WORKDIR}/ucode/kernel/x86/microcode | ||
28 | ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool --overwrite --write-to=${WORKDIR}/microcode_${PV}.bin ${WORKDIR}/microcode.dat | ||
29 | |||
30 | ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool --overwrite --write-earlyfw=${WORKDIR}/microcode_${PV}.cpio ${WORKDIR}/microcode.dat | ||
31 | } | ||
32 | |||
33 | do_install() { | ||
34 | install -d ${D}${base_libdir}/firmware/intel-ucode/ | ||
35 | install ${WORKDIR}/microcode_${PV}.bin ${D}${base_libdir}/firmware/intel-ucode/ | ||
36 | cd ${D}${base_libdir}/firmware/intel-ucode/ | ||
37 | ln -sf microcode_${PV}.bin microcode.bin | ||
38 | } | ||
39 | |||
40 | do_deploy() { | ||
41 | install -d ${DEPLOYDIR} | ||
42 | install ${S}/microcode_${PV}.cpio ${DEPLOYDIR}/ | ||
43 | cd ${DEPLOYDIR} | ||
44 | rm -f microcode.cpio | ||
45 | ln -sf microcode_${PV}.cpio microcode.cpio | ||
46 | } | ||
47 | |||
48 | addtask deploy before do_build after do_compile | ||
49 | |||
50 | PACKAGES = "${PN}" | ||
51 | |||
52 | FILES_${PN} = "${base_libdir}" | ||