summaryrefslogtreecommitdiffstats
path: root/common/recipes-core/ovmf/ovmf-shell-image-enrollkeys.bb
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2017-08-28 15:18:59 -0700
committerSaul Wold <sgw@linux.intel.com>2017-08-30 14:25:24 -0700
commit7465f7fc99d11f469382bacae514ccfc5006dbe1 (patch)
treedeaa3e1e79fe7f35b2e45e1b6cc2b4710978e7ef /common/recipes-core/ovmf/ovmf-shell-image-enrollkeys.bb
parentb03fee437831c35d7064241703704045d7aa3820 (diff)
downloadmeta-intel-7465f7fc99d11f469382bacae514ccfc5006dbe1.tar.gz
ovmf: add secureboot bits from refkit
This patch adds a couple secureboot elements to ovmf that originated from refkit. It includes a patch that adds a certificate to the ovmf's enrolled keys, and an image recipe which calls the enrollkeys app. Original work by Mikko Ylinen and Patrick Ohly. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-core/ovmf/ovmf-shell-image-enrollkeys.bb')
-rw-r--r--common/recipes-core/ovmf/ovmf-shell-image-enrollkeys.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/common/recipes-core/ovmf/ovmf-shell-image-enrollkeys.bb b/common/recipes-core/ovmf/ovmf-shell-image-enrollkeys.bb
new file mode 100644
index 00000000..b20f6e58
--- /dev/null
+++ b/common/recipes-core/ovmf/ovmf-shell-image-enrollkeys.bb
@@ -0,0 +1,13 @@
1require recipes-core/ovmf/ovmf-shell-image.bb
2
3WKS_SEARCH_PATH_append = ":${COREBASE}/meta/recipes-core/ovmf"
4
5QB_DRIVE_TYPE = "/dev/vd"
6
7do_image_append() {
8 cat > ${IMAGE_ROOTFS}/startup.nsh << EOF
9EnrollDefaultKeys
10reset
11EOF
12
13}