summaryrefslogtreecommitdiffstats
path: root/common/recipes-core/microcode/intel-microcode_20150121.bb
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2015-09-01 08:23:45 -0500
committerSaul Wold <sgw@linux.intel.com>2015-09-01 09:24:13 -0700
commit92705cccb52472f119172557e67c1fd1e39e0d01 (patch)
treee6ce7c0e5c3067ba7368d110359769eaf9767ce2 /common/recipes-core/microcode/intel-microcode_20150121.bb
parenta9c38306c91e7cfb0171bc4e3d594bc638d813da (diff)
downloadmeta-intel-92705cccb52472f119172557e67c1fd1e39e0d01.tar.gz
intel-microcode: bump version to 20150121
Bumped version to 20150121. Dropped runtime dependency on iucode-tool which is used to generate the cpio or trim down the data file based on your CPU. While it can also be used to load the microcode that is not the recommended method for Linux 3.9 and newer instead you should use the kernel's built-in early microcode loading facilities. Signed-off-by: Doug Goldstein <cardoe@cardoe.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-core/microcode/intel-microcode_20150121.bb')
-rw-r--r--common/recipes-core/microcode/intel-microcode_20150121.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/common/recipes-core/microcode/intel-microcode_20150121.bb b/common/recipes-core/microcode/intel-microcode_20150121.bb
new file mode 100644
index 00000000..f51af537
--- /dev/null
+++ b/common/recipes-core/microcode/intel-microcode_20150121.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Intel Processor Microcode Datafile for Linux"
2HOMEPAGE = "http://www.intel.com/"
3DESCRIPTION = "The microcode data file contains the latest microcode\
4 definitions for all Intel processors. Intel releases microcode updates\
5 to correct processor behavior as documented in the respective processor\
6 specification updates. While the regular approach to getting this microcode\
7 update is via a BIOS upgrade, Intel realizes that this can be an\
8 administrative hassle. The Linux operating system and VMware ESX\
9 products have a mechanism to update the microcode after booting.\
10 For example, this file will be used by the operating system mechanism\
11 if the file is placed in the /etc/firmware directory of the Linux system."
12
13LICENSE = "Intel-Microcode-License"
14LIC_FILES_CHKSUM = "file://microcode.dat;md5=dfedc580c52db32c762669b7652178b7"
15
16SRC_URI = "http://downloadmirror.intel.com/24661/eng/microcode-${PV}.tgz"
17SRC_URI[md5sum] = "639b7f2af0a822fe006a4fa2ddf8052f"
18SRC_URI[sha256sum] = "23353b93bb421971496cea5e9f9d390ce0ed22580a8cc45ae7b3b322dcd8f6b3"
19
20DEPENDS = "iucode-tool-native"
21S = "${WORKDIR}"
22
23COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26inherit deploy
27
28# Use any of the iucode_tool parameters to filter specific microcodes from the data file
29# For further information, check the iucode-tool's manpage : http://manned.org/iucode-tool
30UCODE_FILTER_PARAMETERS ?= ""
31
32do_compile() {
33 mkdir -p ${WORKDIR}/ucode/kernel/x86/microcode
34 ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
35 ${UCODE_FILTER_PARAMETERS} \
36 --overwrite \
37 --write-to=${WORKDIR}/microcode_${PV}.bin \
38 ${WORKDIR}/microcode.dat
39
40 ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \
41 ${UCODE_FILTER_PARAMETERS} \
42 --overwrite \
43 --write-earlyfw=${WORKDIR}/microcode_${PV}.cpio \
44 ${WORKDIR}/microcode.dat
45}
46
47do_install() {
48 install -d ${D}${base_libdir}/firmware/intel-ucode/
49 install ${WORKDIR}/microcode_${PV}.bin ${D}${base_libdir}/firmware/intel-ucode/
50 cd ${D}${base_libdir}/firmware/intel-ucode/
51 ln -sf microcode_${PV}.bin microcode.bin
52}
53
54do_deploy() {
55 install -d ${DEPLOYDIR}
56 install ${S}/microcode_${PV}.cpio ${DEPLOYDIR}/
57 cd ${DEPLOYDIR}
58 rm -f microcode.cpio
59 ln -sf microcode_${PV}.cpio microcode.cpio
60}
61
62addtask deploy before do_build after do_compile
63
64PACKAGES = "${PN}"
65
66FILES_${PN} = "${base_libdir}"