summaryrefslogtreecommitdiffstats
path: root/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
diff options
context:
space:
mode:
authorKishore Bodke <kishore.k.bodke@intel.com>2013-03-26 14:05:47 -0700
committerTom Zanussi <tom.zanussi@intel.com>2013-03-26 15:38:36 -0500
commit294487ac822b0c9b9f4ff7861c0b67b43e99a781 (patch)
tree7cd3bab361dfc9df8551a8ccbd883419b7b26adf /common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
parent2e8760d272aa2c62b41cbf768445c99569604c5e (diff)
downloadmeta-intel-294487ac822b0c9b9f4ff7861c0b67b43e99a781.tar.gz
meta-intel/common: Fix build issues for openssl-qat-module
openssl-qat-module and zlib-qat-module recipes have the same kernel module name, which causes the build to fail. This fixes Bug 4126 - Crystal Forest build failing for openssl-qat-module ERROR: Recipe openssl-qat-module is trying to create package kernel-module-qat-mem which was already written by recipe zlib-qat-module. This will cause corruption, please resolve this and only provide the package from one recipe or the other or only build one of the recipes. ERROR: Function failed: read_subpackage_metadata ERROR: Execution of event handler 'run_buildstats' failed Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com>
Diffstat (limited to 'common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb')
-rw-r--r--common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
index fdeebbb8..fb863b0a 100644
--- a/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
+++ b/common/recipes-connectivity/openssl-qat-module/openssl-qat-module.bb
@@ -45,6 +45,14 @@ do_compile() {
45 oe_runmake KERNEL_CC="${KERNEL_CC}" 45 oe_runmake KERNEL_CC="${KERNEL_CC}"
46} 46}
47 47
48KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
49MODULE_DIR="${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers"
50
51do_install() {
52 install -m 0755 -d ${MODULE_DIR}
53 install -m 0755 ${S}/qat_mem.ko ${MODULE_DIR}
54}
55
48do_install_append() { 56do_install_append() {
49 install -m 0755 -d ${D}${bindir} \ 57 install -m 0755 -d ${D}${bindir} \
50 ${D}${includedir}/engines/qat_engine/qat_mem 58 ${D}${includedir}/engines/qat_engine/qat_mem
@@ -53,4 +61,5 @@ do_install_append() {
53 install -m 0750 ${S}/*.h ${D}${includedir}/engines/qat_engine/qat_mem/ 61 install -m 0750 ${S}/*.h ${D}${includedir}/engines/qat_engine/qat_mem/
54} 62}
55 63
56FILES_${PN} += "${bindir}/qat_mem_test" 64FILES_${PN} += "${bindir}/qat_mem_test \
65 ${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers"