diff options
author | Alejandro Hernandez <alejandro.hernandez@linux.intel.com> | 2016-04-22 00:28:12 (GMT) |
---|---|---|
committer | Saul Wold <sgw@linux.intel.com> | 2016-04-22 14:22:15 (GMT) |
commit | d519b9d8e53e1e4dd3494d8a3a8e3e531b2b9788 (patch) | |
tree | b2fda5c5b32533347243cb2582ff92945a616c01 /common/recipes-bsp | |
parent | e05c3b1e86da84c91c1eaeb29598f923cb48659a (diff) | |
download | meta-intel-d519b9d8e53e1e4dd3494d8a3a8e3e531b2b9788.tar.gz |
gma500-gfx-check: Fix dependency to meta-poky
The gma500-gfx-check we used had a dependency to meta-poky via a bbappend file
this is unnacceptable, but this check is still needed on genericx86 and
intel-core2-32, so this patch makes copy of the gma500-gfx-check to meta-intel
to avoid the dependency issue
[YOCTO #9181]
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-bsp')
4 files changed, 35 insertions, 1 deletions
diff --git a/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.conf b/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.conf new file mode 100644 index 0000000..74d33c8 --- /dev/null +++ b/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.conf | |||
@@ -0,0 +1,2 @@ | |||
1 | # Mimic modprobe's install funcitonality with busybox's modprobe | ||
2 | install gma500_gfx dmesg | grep gma500_gfx_checked || { /etc/modprobe.d/gma500-gfx-check.sh || modprobe gma500_gfx; } | ||
diff --git a/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.sh b/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.sh new file mode 100644 index 0000000..75cda99 --- /dev/null +++ b/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check/gma500-gfx-check.sh | |||
@@ -0,0 +1,15 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | # Check for devices we wish to avoid gma500_gfx for | ||
4 | DEVICES="0x8119 0x4108" | ||
5 | |||
6 | # Checked flag to avoid infinite modprobe | ||
7 | echo "gma500_gfx_checked" >> /dev/kmsg; | ||
8 | |||
9 | for DEVICE in $DEVICES; do | ||
10 | if udevadm trigger --subsystem-match=pci --verbose --attr-match=device=$DEVICE | grep "pci" >> /dev/null ; then | ||
11 | echo "Found $DEVICE, avoiding gma500_gfx module" >> /dev/kmsg; | ||
12 | exit 0 | ||
13 | fi | ||
14 | done | ||
15 | exit 1 | ||
diff --git a/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb b/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb new file mode 100644 index 0000000..7b08064 --- /dev/null +++ b/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | SUMMARY = "Intel gma500_gfx fix for certain hardware" | ||
2 | DESCRIPTION = "Avoid inserting gma500_gfx module for certain hardware devices." | ||
3 | LICENSE="GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | ||
5 | |||
6 | SRC_URI = "file://gma500-gfx-check.conf \ | ||
7 | file://gma500-gfx-check.sh " | ||
8 | |||
9 | do_install(){ | ||
10 | install -d ${D}${sysconfdir}/modprobe.d/ | ||
11 | install -m 755 ${WORKDIR}/gma500-gfx-check.sh ${D}${sysconfdir}/modprobe.d/gma500-gfx-check.sh | ||
12 | install -m 644 ${WORKDIR}/gma500-gfx-check.conf ${D}${sysconfdir}/modprobe.d/gma500-gfx-check.conf | ||
13 | } | ||
14 | |||
15 | FILES_${PN}="${sysconfdir}/modprobe.d/gma500-gfx-check.conf \ | ||
16 | ${sysconfdir}/modprobe.d/gma500-gfx-check.sh" | ||
17 | |||
18 | COMPATIBLE_MACHINE = "intel-core2-32" | ||
diff --git a/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bbappend b/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bbappend deleted file mode 100644 index eb8a724..0000000 --- a/common/recipes-bsp/gma500-gfx-check/gma500-gfx-check_1.0.bbappend +++ /dev/null | |||
@@ -1 +0,0 @@ | |||
1 | COMPATIBLE_MACHINE = "intel-core2-32" | ||