summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-24 12:56:34 -0700
committerSaul Wold <sgw@linux.intel.com>2017-09-05 07:28:53 -0700
commitc8b3164190485ca2999e5efadbc20a3418c7c692 (patch)
tree07b86c3b50b0f08606e6cdfa66639dbfae180067 /common/recipes-bsp
parent8d44e72d6eff173d96eb5b2571e8c1e10de53816 (diff)
downloadmeta-intel-c8b3164190485ca2999e5efadbc20a3418c7c692.tar.gz
rmc: Add -fno-stack-protector
Some toolchains may have configured itself with ssp in such cases just removing -fstack-protector-strong is not enough to disable ssp, additionally disabling it on cmdline is required too Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-bsp')
-rw-r--r--common/recipes-bsp/rmc/rmc-efi.bb1
-rw-r--r--common/recipes-bsp/rmc/rmc.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/common/recipes-bsp/rmc/rmc-efi.bb b/common/recipes-bsp/rmc/rmc-efi.bb
index ea096197..2a1c9a98 100644
--- a/common/recipes-bsp/rmc/rmc-efi.bb
+++ b/common/recipes-bsp/rmc/rmc-efi.bb
@@ -21,6 +21,7 @@ EXTRA_OEMAKE = "RMC_INSTALL_PREFIX=${D}/${prefix} \
21 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc" 21 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc"
22 22
23SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong" 23SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong"
24SECURITY_CFLAGS_append_class-target = " -fno-stack-protector"
24 25
25python () { 26python () {
26 ccargs = d.getVar('TUNE_CCARGS').split() 27 ccargs = d.getVar('TUNE_CCARGS').split()
diff --git a/common/recipes-bsp/rmc/rmc.bb b/common/recipes-bsp/rmc/rmc.bb
index fb0d1737..8797644b 100644
--- a/common/recipes-bsp/rmc/rmc.bb
+++ b/common/recipes-bsp/rmc/rmc.bb
@@ -28,6 +28,7 @@ EXTRA_OEMAKE = "RMC_INSTALL_PREFIX=${D}/${prefix} \
28 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc" 28 RMC_INSTALL_HEADER_PATH=${D}${includedir}/rmc"
29 29
30SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong" 30SECURITY_CFLAGS_remove_class-target = "-fstack-protector-strong"
31SECURITY_CFLAGS_append_class-target = " -fno-stack-protector"
31 32
32do_compile_class-target() { 33do_compile_class-target() {
33 oe_runmake 34 oe_runmake