summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2016-10-26 16:04:56 -0700
committerSaul Wold <sgw@linux.intel.com>2016-11-02 13:50:46 -0700
commitab79b789ace7272a1b7f8225ccbd111e806aad40 (patch)
tree7ad9d6d0c77ced3fa6e0c71ed8d4d4566f943fdc /common/recipes-bsp
parent8649d6b5b1debccceb502241f9dae4353bdf79e1 (diff)
downloadmeta-intel-ab79b789ace7272a1b7f8225ccbd111e806aad40.tar.gz
systemd-boot: add patch for Joule BIOS keyboard hang
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-bsp')
-rw-r--r--common/recipes-bsp/systemd-boot/systemd-boot.bbappend3
-rw-r--r--common/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch31
2 files changed, 33 insertions, 1 deletions
diff --git a/common/recipes-bsp/systemd-boot/systemd-boot.bbappend b/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
index f42434c1..0da0c46a 100644
--- a/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
+++ b/common/recipes-bsp/systemd-boot/systemd-boot.bbappend
@@ -17,4 +17,5 @@ SRCREV = "3a74d4fc90cb322a4784a3515bef7118c8f8c5ba"
17SRC_URI += "file://0001-sd-boot-Link-RMC-libraries-into-bootloader.patch \ 17SRC_URI += "file://0001-sd-boot-Link-RMC-libraries-into-bootloader.patch \
18 file://0002-sd-boot-Load-board-specific-boot-entries-from-RMC-da.patch \ 18 file://0002-sd-boot-Load-board-specific-boot-entries-from-RMC-da.patch \
19 file://0003-sd-boot-Support-global-kernel-command-line-fragment.patch \ 19 file://0003-sd-boot-Support-global-kernel-command-line-fragment.patch \
20 " 20 file://0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch \
21 "
diff --git a/common/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch b/common/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch
new file mode 100644
index 00000000..8d0b6149
--- /dev/null
+++ b/common/recipes-bsp/systemd-boot/systemd-boot/0001-efi-boot.c-workaround-for-Joule-BIOS-hang.patch
@@ -0,0 +1,31 @@
1From 58669ad764767afea4de53f8a97357773b1855ef Mon Sep 17 00:00:00 2001
2From: Saul Wold <sgw@linux.intel.com>
3Date: Tue, 25 Oct 2016 12:54:08 -0700
4Subject: [PATCH] efi/boot.c: workaround for Joule BIOS hang
5
6This patch should be removed when the BIOS is fixed
7
8Authored-by: Steve Sakoman <steve@sakoman.com>
9
10Upstream-Status: Inappropriate [machine specific workaround]
11Signed-off-by: Saul Wold <sgw@linux.intel.com>
12---
13 src/boot/efi/boot.c | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/src/boot/efi/boot.c b/src/boot/efi/boot.c
17index 3dcd9a5..3c6ed8c 100644
18--- a/src/boot/efi/boot.c
19+++ b/src/boot/efi/boot.c
20@@ -649,7 +649,7 @@ static BOOLEAN menu_run(Config *config, ConfigEntry **chosen_entry, CHAR16 *load
21 }
22
23 /* timeout disabled, wait for next key */
24- wait = TRUE;
25+ wait = FALSE;
26 continue;
27 }
28
29--
302.7.4
31