summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2017-09-11 17:31:29 -0700
committerSaul Wold <sgw@linux.intel.com>2017-09-12 08:37:53 -0700
commit6e9bad66daa41153582c50398cd9abf54ffddeb2 (patch)
treea3cfeb79f07c69efcf22495fd32dc5ea2007010b /common/recipes-bsp
parent868758cc6610e22a111c0307464182c1a1ffe35a (diff)
downloadmeta-intel-6e9bad66daa41153582c50398cd9abf54ffddeb2.tar.gz
systemd-boot: fix Yocto Project compatibility issue
do_compile and do_deploy were being appended to unconditionally. Fix the issue by using the intel-x86-common MACHINEOVERRIDE. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'common/recipes-bsp')
-rw-r--r--common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend6
1 files changed, 3 insertions, 3 deletions
diff --git a/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend b/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
index 9e407ea5..557c0493 100644
--- a/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
+++ b/common/recipes-bsp/systemd-boot/systemd-boot_%.bbappend
@@ -1,4 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/systemd-boot:" 1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/systemd-boot:"
2 2
3# Pin systemd revision down for systemd-boot recipe. 3# Pin systemd revision down for systemd-boot recipe.
4# Patches could not be applied cleanly when systemd in OE is updated, 4# Patches could not be applied cleanly when systemd in OE is updated,
@@ -14,10 +14,10 @@ include systemd-boot/${EFI_PROVIDER}.inc
14 14
15PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}" 15PACKAGE_ARCH_intel-x86-common = "${INTEL_COMMON_PACKAGE_ARCH}"
16 16
17do_compile_append() { 17do_compile_append_intel-x86-common() {
18 oe_runmake linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub 18 oe_runmake linux${SYSTEMD_BOOT_EFI_ARCH}.efi.stub
19} 19}
20 20
21do_deploy_append() { 21do_deploy_append_intel-x86-common() {
22 install ${B}/linux*.efi.stub ${DEPLOYDIR} 22 install ${B}/linux*.efi.stub ${DEPLOYDIR}
23} 23}