summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2016-05-16 10:01:49 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2016-05-18 16:07:41 -0500
commit6dc3746443523a02f72bf5142cfbe3a800d32f4a (patch)
tree947edf9928784309b05e81659d1d7015be9c35e6 /common/recipes-bsp
parentd87917772ca9597ddd19c8b743212b8dae434b41 (diff)
downloadmeta-intel-6dc3746443523a02f72bf5142cfbe3a800d32f4a.tar.gz
lms8: Add patch to fix gcc6 C++ whitespace
This adds a patch to lms8 to fix an error cause by the newer C++11 standard being enabled in GCC6 that requires additional whitespace around User-Defined literals. [YOCTO #9640] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'common/recipes-bsp')
-rw-r--r--common/recipes-bsp/amt/lms/0001-Protocol.cpp-Add-whitespace-for-gcc6-compile-error.patch31
-rw-r--r--common/recipes-bsp/amt/lms8_8.0.0-7.bb4
2 files changed, 34 insertions, 1 deletions
diff --git a/common/recipes-bsp/amt/lms/0001-Protocol.cpp-Add-whitespace-for-gcc6-compile-error.patch b/common/recipes-bsp/amt/lms/0001-Protocol.cpp-Add-whitespace-for-gcc6-compile-error.patch
new file mode 100644
index 00000000..17b206e2
--- /dev/null
+++ b/common/recipes-bsp/amt/lms/0001-Protocol.cpp-Add-whitespace-for-gcc6-compile-error.patch
@@ -0,0 +1,31 @@
1From 8d737ba9745bef223c3d3b96899f11c26102ea04 Mon Sep 17 00:00:00 2001
2From: Saul Wold <sgw@linux.intel.com>
3Date: Mon, 16 May 2016 09:01:05 -0700
4Subject: [PATCH] Protocol.cpp: Add whitespace for gcc6 compile error
5
6When moving from C++-3 -> C++11 additiona white space is required between
7User-defined literals.
8
9Upstream-Status: Pending
10
11Signed-off-by: Saul Wold <sgw@linux.intel.com>
12---
13 src/Protocol.cpp | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/src/Protocol.cpp b/src/Protocol.cpp
17index 1c21a0f..3a4a9bb 100755
18--- a/src/Protocol.cpp
19+++ b/src/Protocol.cpp
20@@ -1428,7 +1428,7 @@ int Protocol::_handleFQDNChange(const char *fqdn)
21 char host[FQDN_MAX_SIZE + 1];
22 #define LMS_MAX_LINE_LEN 1023
23 char line[LMS_MAX_LINE_LEN + 1];
24-#define LMS_LINE_SIG_FIRST_WORDS(a) "# LMS GENERATED "a" "
25+#define LMS_LINE_SIG_FIRST_WORDS(a) "# LMS GENERATED " a " "
26 #define LMS_LINE_SIG_LAST_WORD "LINE"
27 #define LMS_LINE_SIG_LAST_WORD_LEN 4
28 #define LMS_LINE_SIG(a) LMS_LINE_SIG_FIRST_WORDS(a) LMS_LINE_SIG_LAST_WORD
29--
302.5.0
31
diff --git a/common/recipes-bsp/amt/lms8_8.0.0-7.bb b/common/recipes-bsp/amt/lms8_8.0.0-7.bb
index 65c413a8..7989d59e 100644
--- a/common/recipes-bsp/amt/lms8_8.0.0-7.bb
+++ b/common/recipes-bsp/amt/lms8_8.0.0-7.bb
@@ -8,7 +8,9 @@ LICENSE = "BSD_LMS"
8PR = "r0" 8PR = "r0"
9BPN="lms" 9BPN="lms"
10SRC_URI = "http://software.intel.com/sites/default/files/${BPN}-${PV}.tar.gz \ 10SRC_URI = "http://software.intel.com/sites/default/files/${BPN}-${PV}.tar.gz \
11 file://readlink-declaration.patch" 11 file://readlink-declaration.patch \
12 file://0001-Protocol.cpp-Add-whitespace-for-gcc6-compile-error.patch \
13 "
12 14
13COMPATIBLE_HOST = '(i.86|x86_64).*-linux' 15COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
14 16