summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-06-04 12:18:13 +0000
committerTom Zanussi <tom.zanussi@intel.com>2013-06-12 11:13:30 -0500
commit523f0945d147e1c73276b15b5fa89cedacc0982b (patch)
treeee4c946ff0b743467b94d71c483bf36220687142 /common/recipes-bsp
parentedd694ef677bce72fbb89fad82a352e381f21b45 (diff)
downloadmeta-intel-523f0945d147e1c73276b15b5fa89cedacc0982b.tar.gz
lms7: reorganize the lms recipe
Preparations for upcoming lms8 recipe. Rename the lms recipe as lms7. This will allow BSPs to choose either lms7 or lms8 package to suite the version 7 or 8 firmware available on the board. Also the lms binary & script is renamed to lms7 to avoid runtime clash with lms8 packages. Simplified the dounpack2 function. And this build time warning is muted: WARNING: lms7: No generic license file exists for: Modified in any provider Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> lms7 : tail conexist Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'common/recipes-bsp')
-rw-r--r--common/recipes-bsp/amt/files/atnetworktool-printf-fix.patch (renamed from common/recipes-bsp/amt/lms/atnetworktool-printf-fix.patch)0
-rw-r--r--common/recipes-bsp/amt/files/readlink-declaration.patch (renamed from common/recipes-bsp/amt/lms/readlink-declaration.patch)0
-rw-r--r--common/recipes-bsp/amt/lms7_7.1.20.bb (renamed from common/recipes-bsp/amt/lms_7.1.20.bb)27
3 files changed, 11 insertions, 16 deletions
diff --git a/common/recipes-bsp/amt/lms/atnetworktool-printf-fix.patch b/common/recipes-bsp/amt/files/atnetworktool-printf-fix.patch
index 6bb03e3a..6bb03e3a 100644
--- a/common/recipes-bsp/amt/lms/atnetworktool-printf-fix.patch
+++ b/common/recipes-bsp/amt/files/atnetworktool-printf-fix.patch
diff --git a/common/recipes-bsp/amt/lms/readlink-declaration.patch b/common/recipes-bsp/amt/files/readlink-declaration.patch
index 0246d501..0246d501 100644
--- a/common/recipes-bsp/amt/lms/readlink-declaration.patch
+++ b/common/recipes-bsp/amt/files/readlink-declaration.patch
diff --git a/common/recipes-bsp/amt/lms_7.1.20.bb b/common/recipes-bsp/amt/lms7_7.1.20.bb
index 1a901f7b..2c6a29e1 100644
--- a/common/recipes-bsp/amt/lms_7.1.20.bb
+++ b/common/recipes-bsp/amt/lms7_7.1.20.bb
@@ -3,10 +3,12 @@ to access the Intel Active Management Technology (AMT) firmware via \
3the Intel Management Engine Interface (MEI)." 3the Intel Management Engine Interface (MEI)."
4HOMEPAGE = "http://software.intel.com/en-us/articles/download-the-latest-intel-amt-open-source-drivers" 4HOMEPAGE = "http://software.intel.com/en-us/articles/download-the-latest-intel-amt-open-source-drivers"
5 5
6LICENSE = "Modified BSD" 6LICENSE = "BSD_LMS"
7 7
8PR = "r0" 8PR = "r0"
9SRC_URI = "http://software.intel.com/file/37962 \ 9BPN="lms"
10PV_SUB = "25"
11SRC_URI = "http://software.intel.com/file/37962;downloadfilename=${BPN}+${PV}.${PV_SUB}.zip \
10 file://atnetworktool-printf-fix.patch \ 12 file://atnetworktool-printf-fix.patch \
11 file://readlink-declaration.patch" 13 file://readlink-declaration.patch"
12 14
@@ -19,27 +21,20 @@ SRC_URI[sha256sum] = "cc0457f0044e924794bb1aeae9a72c28666a525cd8a963d0d929702229
19 21
20inherit autotools update-rc.d 22inherit autotools update-rc.d
21 23
22INITSCRIPT_NAME = "lms" 24INITSCRIPT_NAME = "lms7"
23INITSCRIPT_PARAMS = "defaults" 25INITSCRIPT_PARAMS = "defaults"
24 26
25PV_SUB = "25"
26
27do_unpack2() { 27do_unpack2() {
28 # The downloaded 37962 filename is actually lms+7.1.20.25.zip. 28 cd ${WORKDIR}
29 # It contains lms-7.1.20-25.tar.gz. 29 tar -xvzf ${WORKDIR}/outputdir/lms-${PV}-${PV_SUB}.tar.gz
30 # It contains lms-7.1.20-25.tar.gz untars to lms-7.1.20
31 if [ -e "${WORKDIR}/37962" ]; then
32 mv ${WORKDIR}/37962 ${WORKDIR}/${PN}+${PV}.${PV_SUB}.zip
33 unzip -o ${WORKDIR}/${PN}+${PV}.${PV_SUB}.zip
34 mv ${WORKDIR}/${PN}-${PV}/outputdir/${PN}-${PV}-${PV_SUB}.tar.gz ${WORKDIR}/
35 cd ${WORKDIR}
36 tar -xvzf ${PN}-${PV}-${PV_SUB}.tar.gz
37 fi
38} 30}
39 31
40addtask unpack2 after do_unpack before do_patch 32addtask unpack2 after do_unpack before do_patch
41 33
42do_install_append () { 34do_install_append () {
35 mv ${D}/${sbindir}/lms ${D}/${sbindir}/lms7
43 install -d ${D}${sysconfdir}/init.d 36 install -d ${D}${sysconfdir}/init.d
44 install -m 0755 ${WORKDIR}/${PN}-${PV}/scripts/lms ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} 37 mv ${D}${sysconfdir}/rc.d/init.d/lms ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
38 sed -i 's/^NAME=lms/NAME=lms7/' ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
39 rmdir ${D}${datadir} || :
45} 40}