summaryrefslogtreecommitdiffstats
path: root/common/recipes-bsp/efilinux
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-03-20 17:31:26 -0700
committerDarren Hart <dvhart@linux.intel.com>2012-03-23 08:12:30 -0700
commitb508457fbf3674cd573f00d972aca55048c015cf (patch)
tree8e6f4b982a396ed1ab60e613b7f53d17c280b877 /common/recipes-bsp/efilinux
parent2cd93a046edf78537297ecfe8c1ef10520734e89 (diff)
downloadmeta-intel-b508457fbf3674cd573f00d972aca55048c015cf.tar.gz
efilinux: Add efilinux 1.0 and gnu-efi
efilinux is a UEFI OS loader. It was created as a reference implementation with the aim of being well documented and containing well written source code. efilinux is lightweight and convenient as a tool to debug misbehaving UEFI systems. Thanks to Paul Eggleton for is initial set of recipes from which these were based. Signed-off-by: Darren Hart <dvhart@linux.intel.com> CC: Paul Eggleton <paul.eggleton@linux.intel.com> CC: Tom Zanussi <tom.zanussi@intel.com> CC: Kishore K Bodke <kishore.k.bodke@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'common/recipes-bsp/efilinux')
-rw-r--r--common/recipes-bsp/efilinux/efilinux_1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/common/recipes-bsp/efilinux/efilinux_1.0.bb b/common/recipes-bsp/efilinux/efilinux_1.0.bb
new file mode 100644
index 00000000..2a7bf6bf
--- /dev/null
+++ b/common/recipes-bsp/efilinux/efilinux_1.0.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "A UEFI OS loader"
2LICENSE = "efilinux"
3LIC_FILES_CHKSUM = "file://efilinux.h;beginline=5;endline=31;md5=2316abda893ef24e6cd55cef33aa0edd"
4
5DEPENDS = "gnu-efi"
6
7inherit deploy
8
9SRCREV = "75b62111f83dab433e901c1a7b0f05e058aa29de"
10PV = "1.0+git${SRCPV}"
11PR = "r0"
12
13SRC_URI = "git://git.kernel.org/pub/scm/boot/efilinux/efilinux.git"
14
15S = "${WORKDIR}/git"
16
17COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
18
19EXTRA_OEMAKE = "INCDIR=${STAGING_INCDIR} LIBDIR=${STAGING_LIBDIR}"
20
21# syslinux uses $LD for linking, strip `-Wl,' so it can work
22export LDFLAGS = "`echo $LDFLAGS | sed 's/-Wl,//g'`"
23
24do_deploy () {
25 install ${S}/efilinux.efi ${DEPLOYDIR}/efilinux.efi
26}
27addtask deploy before do_build after do_compile
28