summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2018-01-23 15:14:39 -0800
committerCalifornia Sullivan <california.l.sullivan@intel.com>2018-01-23 15:49:51 -0800
commitf3f1be4f5af99dd76566871fa989fabc4f6b037e (patch)
tree7bfec7ec545e9add300bdc5c6b9336e11fbce102
parentaf420750a3098b38959dac59c08a56c22941ca2e (diff)
downloadmeta-intel-f3f1be4f5af99dd76566871fa989fabc4f6b037e.tar.gz
linux-intel/4.14: add preempt-rt recipe
Adds the 4.14.12 kernel with the rt10 patches applied. Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.14.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.14.bb b/recipes-kernel/linux/linux-intel-rt_4.14.bb
new file mode 100644
index 00000000..9846ccd9
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_4.14.bb
@@ -0,0 +1,24 @@
1require linux-intel.inc
2
3# Skip processing of this recipe if it is not explicitly specified as the
4# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
5# to build multiple virtual/kernel providers, e.g. as dependency of
6# core-image-rt-sdk, core-image-rt.
7python () {
8 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
9 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
10}
11
12KBRANCH = "4.14/yocto/base-rt"
13KMETA_BRANCH = "master"
14
15# Fix for 32-bit perf issue. Remove when patch is backported to 4.14.
16SRC_URI_append = " file://0001-perf-x86-32-explicitly-include-errno.h.patch"
17
18DEPENDS += "elfutils-native openssl-native util-linux-native"
19
20LINUX_VERSION ?= "4.14.12"
21SRCREV_machine ?= "e6c754497fe1b52ade748218f2491a2c99209292"
22SRCREV_meta ?= "ee7e849882aa2f0947dd56a60ba5b0d2eec558f2"
23
24LINUX_KERNEL_TYPE = "preempt-rt"