summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLim Siew Hoon <siew.hoon.lim@intel.com>2020-12-24 11:28:22 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-12-24 11:33:28 +0800
commite8e901aac795f23a985615e03b9194012b164542 (patch)
tree31e8317b05a2de3148773057a28e93d2bfe36c24
parent64c7aba6add3611060117c1475ae72896e3963ad (diff)
downloadmeta-intel-e8e901aac795f23a985615e03b9194012b164542.tar.gz
intel-media-driver: backport fixed VP9 444 frame header.
Fixes VP9 444 encode output not able decode with gstreamer-vaapi master. Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-multimedia/libva/files/0001-Encode-Fixed-VP9-444-frame-header.patch43
-rw-r--r--recipes-multimedia/libva/intel-media-driver_20.3.0.bb1
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes-multimedia/libva/files/0001-Encode-Fixed-VP9-444-frame-header.patch b/recipes-multimedia/libva/files/0001-Encode-Fixed-VP9-444-frame-header.patch
new file mode 100644
index 00000000..cd046c65
--- /dev/null
+++ b/recipes-multimedia/libva/files/0001-Encode-Fixed-VP9-444-frame-header.patch
@@ -0,0 +1,43 @@
1From 24da63ad1e0215b103c29b1bce29e126ca94ba00 Mon Sep 17 00:00:00 2001
2From: Lim Siew Hoon <siew.hoon.lim@intel.com>
3Date: Thu, 17 Dec 2020 14:33:21 +0800
4Subject: [PATCH] [Encode] Fixed VP9 444 frame header
5
6According VP9 spec section 7.2.2 color config semantics,
7both subsampling_x and subsampling_y should be 0 for YUV444.
8Only YUV440 subsampling_x=0 and subsampling_y=1.
9
10fixes #1074
11
12Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
13
14The patch was imported from the iHD media-driver git server
15(https://github.com/intel/media-driver.git) as of commit id
16a33eaaec2f71f04c8850db9287ee4012e143e283.
17
18Upstream-status: Backport
19
20Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com>
21---
22 media_driver/linux/common/codec/ddi/media_libvpx_vp9.cpp | 4 ++--
23 1 file changed, 2 insertions(+), 2 deletions(-)
24
25diff --git a/media_driver/linux/common/codec/ddi/media_libvpx_vp9.cpp b/media_driver/linux/common/codec/ddi/media_libvpx_vp9.cpp
26index df89f4fe..41357b0e 100644
27--- a/media_driver/linux/common/codec/ddi/media_libvpx_vp9.cpp
28+++ b/media_driver/linux/common/codec/ddi/media_libvpx_vp9.cpp
29@@ -97,9 +97,9 @@ void write_bitdepth_colorspace_sampling(uint32_t codecProfile,
30 (codecProfile == VP9_PROFILE_3))
31 {
32 /* sub_sampling_x/y */
33- /* Currently the sub_sampling_x = 0, sub_sampling_y = 1 */
34+ /* Currently the sub_sampling_x = 0, sub_sampling_y = 0 */
35+ vp9_wb_write_bit(wb, 0);
36 vp9_wb_write_bit(wb, 0);
37- vp9_wb_write_bit(wb, 1);
38 vp9_wb_write_bit(wb, 0); // unused
39 }
40 }
41--
422.17.1
43
diff --git a/recipes-multimedia/libva/intel-media-driver_20.3.0.bb b/recipes-multimedia/libva/intel-media-driver_20.3.0.bb
index 8e14238a..a53867bd 100644
--- a/recipes-multimedia/libva/intel-media-driver_20.3.0.bb
+++ b/recipes-multimedia/libva/intel-media-driver_20.3.0.bb
@@ -19,6 +19,7 @@ REQUIRED_DISTRO_FEATURES = "opengl"
19DEPENDS += "libva gmmlib" 19DEPENDS += "libva gmmlib"
20 20
21SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;branch=intel-media-20.3 \ 21SRC_URI = "git://github.com/intel/media-driver.git;protocol=https;branch=intel-media-20.3 \
22 file://0001-Encode-Fixed-VP9-444-frame-header.patch \
22 " 23 "
23 24
24SRCREV = "86ec0b6f61862806d8aed1803537728d1dfadf84" 25SRCREV = "86ec0b6f61862806d8aed1803537728d1dfadf84"